Importing data from external NTFS drive

I am fairly new to TrueNAS having just installed it on my new server for the first time last week (Dragonfish-

My old home NAS (Windows) died but I managed to get files off of it onto a NTFS-formatted external drive.

I’m setting up datasets on my new home server and would like to copy over that data. I’ve seen lots of suggestions here but they still haven’t helped me. I’d really prefer to copy the files over locally (external USB drive plugged in) as opposed to via SMB. Mostly to preserve file creation date, etc. Plus speed.

I’ve seen @Arwen saying this is a possibility but I haven’t seen steps outlined anywhere recently. By recently, I know this ‘import disk’ option was taken out of the UI within the last year.

Any ideas on how to do this? Thanks in advance.

I am going off memory here - but I believe the option was taken out because it would bugger up things like file permissions and similar.

Best way to do this is across the LAN

1 Like

And thereby giving new creation dates

Can’t you copy things with rsync and ask it to preserve creation dates?
(going by memory here, I may be misremembering things)

@neofusion Do you mean somehow mount and access that USB drive (that’s not currently in a pool because it’d be erased) and then rsync from there (like the shell cli)?

@NugentS is correct as far as I know, reading NTFS was taken out so you will need to do it over the network either way.

You should be able to attach the drive to a system networked with your TrueNAS system and use rsync on the command line to transfer the files. Man-pages for rsync show:
--crtimes, -N preserve create times (newness)

No guarantees offered here, I have not tested this myself.
As noted, preserving creation times is a newish option, had you only needed to preserve modification dates you’d likely find you had more options. For completeness sake, rsync preserves that with:

--times, -t              preserve modification times

Actually, reading more into this, it might not be that easy, there’s an open issue on it here that suggests that even though it’s documented in the man-pages it might not actually work in Linux:


Edit: Maybe modify date is enough?