Installation fails with checksum error in base package on ugreen NAS

I want to set up my new ugreen NAS DXP2800 with TrueNAS Core 13.1 but keep getting obscure errors during install, although the image checksum matches (downloaded twice to go sure and checked the sha256 hash) and the USB stick is fine (tried different ones even),

The error happens after going through the console installer after the last step, when the installation script is executed:

xceptions. ChecksumFail Exception: %base-os-13.0-U6, 1-00016cd29a68bb56a924d307f65ff55c.tgz has invalid checksum

Strange enough, booting the installer in safe mode, I don’t get that error, but still cannot finish installation; the screen turns black twice for several seconds but then falls back to console saying something about drmi missing.

Please tell me it’s not the hardware…

Full log: (sorry for the cut off, I have no external monitor so I need to use my TV over HDMI ;-):

Installer checksum error 

For: No such device: swap.
records in
records out
152 bytes transferred in 0.006924 secs (302886821 bytes/sec)
/dev/nvd0: short write on character device
/dev/nvd0: end of device
-ecords in
-ecords out
568 bytes transferred in 0.003027 secs (755100618 bytes/sec)
01 added
32 added
-or: No such device: swap.
31 added
32 added
ve set on nyd
aback (most recent call last):
file "/usr/local/bin/freenas-install", line 59, in <module>
if installer.GetPackages() is not True;
file "/usr/local/lib/freenas0S/", line 1072, in GetPackages
pkgFile = self._conf.FindPackageFile(pkg, handler=get_file_handler)
file "/usr/local/lib/freenasOS/", line 1273, in FindPackageFile
raise pkg_exception
nas05. Exceptions. ChecksumFail Exception: %base-os-13.0-U6, 1-00016cd29a68bb56a924d307f65ff55c.tgz has invalid checksum

I now checked the memory with Memtest86+ and it passed, let it run for over 2hrs.
Also tried various BIOS settings and turned Turbo Mode and a Watchdog off (seems to be a ugreen thing that reboots the system when it doesn’t find their own OS “UGOS” running). End result was always the same.

You’d definitely want watchdog off. Other than that, it’s hard to say. I installed 13.3 BETA on my DXP6800 without a problem, having put it on a boot SSD using Ventoy. That’s a lot of variables compared to what you’re doing, but might be worth giving it a try.

Where are you trying to install TrueNAS? It shouldn’t go on the internal eMMC.

Yes, watchdog is weird, thought it was an Intel thing but that it’s tied to UGOS is weird.

Was also thinking about giving the beta a shot, cannot be worse. Downloading now.

I use a Samsung 970 EVO SSD with 256GB as boot and swap drive.

Same with Ventoy and the 13,3 Beta2, sadly.

I checked the checksums and even extracted the ISO content to verify that the package mentioned in the error message is not corrupt, all fine…

Can you try SCALE to see if it behaves differently?

1 Like

sure, but that’s not free, right? sorry need to read up on the docs…
Even checking out OpenMediaVault now, just as a test, but don’t really want to go that route.

Not sure where that idea would have come from. SCALE is free, just as is CORE. CORE is based on FreeBSD; SCALE is based on Linux, but they’re both free.


OK I see. Just thought it was probably overkill since it is all about scalability and I’m just running a private NAS with 2 disks in a mirror-RAID here.

So SCALE finally worked fine for me, install went through without a glitch:)
For some reason, my ugreen NAS doesn’t seem to like BSD…

That was their marketing when it was first announced. In reality, it’s the new version of TrueNAS, and CORE is on its way out. Glad it worked for you, though it remains kind of baffling that CORE didn’t.


Thanks for the information re stategy and your quick and accurate help!

A slight OT followup: can I setup the NAS with just 1 HDD for storage now and migrate to a mirror later? Mirror-RAID has to be setup with 2 disks in place already, and I’m not sure if I can migrate from a 1-disk striped vdev to a 2-disk mirror later…

Update: OK that seems to work just fine: SOLVED - Change stripe vdev layout to mirror | TrueNAS Community

Yes, as you’ve since found. We’d recommend starting with the mirror, but adding the second disk later works just fine also.

1 Like

Hi there,

I was also experiencing this problem with my Ugreen NAS DXP4800. If migrating to SCALE is not an option for you, I was able to successfully install CORE by using a different x64 machine to install the OS onto an SSD before moving the SSD to the Ugreen NAS. TrueNAS CORE boots successfully and I’m not experiencing any errors post-install. It was just the installer not working, I guess.

In my case, I used a Virtualbox VM with a USB to SATA adapter and USB passthrough to the VM to do the installation. But an unused physical computer would work just as well. Just make sure to install with UEFI boot, as in my experience the Ugreen NAS won’t do legacy BIOS boot at all.

If that’s the case, you may also have success by using Ventoy. ie make a Ventoy USB, then pop the iso in the ventoy directory.

Still, If starting out fresh, I would recommend SCALE over CORE anyway.

Thanks but given that SCALE is the more feature-rich and future-proof platform and I’m on Linux anyway, this was no problem.
Works like a charm, but these darn permissions are always a PITA…

I also plan to move to SCALE eventually. But I was moving an old CORE installation to this new hardware and changing both hardware and OS at the same time would have been too complicated for me. (The old hardware used legacy boot, which is why I couldn’t just slot the boot pool SSDs in as-is and boot from them.)

1 Like