Intermittent Network Access Issue on TrueNAS-13.0-U6.1

Hi everyone,

I’m experiencing an intermittent issue with my TrueNAS CORE server (TrueNAS-13.0-U6.1) where it becomes inaccessible over the network every 1-2 weeks. (Happend 5-6 times now, Updates didn’t solve the issue.) Neither the web login nor SMB shares are reachable during these times. Only a hard reboot solves the issue.

However, the system generally runs stable, and the reporting feature shows everything continuing as normal. Even when the TrueNAS cannot be reached via network anymore, the reporting history after the hard reboot shows nothing unusual to me (regarding (CPU idle, plenty of RAM, no disk activity).

My System Specs:

  • CPU: Intel(R) Pentium(R) CPU J4205 @ 1.50GHz
  • Memory: 7.6GiB
  • Storage: 256GB Samsung SSD for OS, and two encrypted HDDs with lz4 compression

I’ve tried looking up similar cases online but haven’t found anything that matches. Being fairly new to TrueNAS, I also couldn’t spot anything unusual in the settings. I’ve briefly checked the logs under /var/log, but I’m not sure what to look for.

Could someone guide me on how to troubleshoot this issue further, or suggest what logs might be relevant to check? Any help would be greatly appreciated! If you need any information, I’m happy to provide it.

Thanks in advance!

Have you set a static IP or are you trusting your router’s DHCP?

In my FritzBox there is an option you can set to make sure the device always receives the same IP. I’ve set this option for my TrueNAS.

Then the next possible culprit is the RAM. Run and if it does not throws any errors, I would suggest adding another 8GB… which apparently you cannot do.
Eh, you have quite an elderly CPU there. What are you using it for?

Hi, are you using a Realtek NIC?

1 Like

Will run memtest asap. Just had a closer look at the reporting and found the Zoom-Out tool I’ver overseen before… *facepalm

RAM Reporting looks like this, so you might be right.

CORE is expected to use all available RAM, and release it when the system needs it.
If you have too many services active however things can get pretty tricky.

pciconf -lv returns I am using a Realtec NIC:

re0@pci0:1:0:0: class=0x020000 rev=0x11 hdr=0x00 vendor=0x10ec device=0x8168 subvendor=0x1849 subdevice=0x8168
    vendor     = 'Realtek Semiconductor Co., Ltd.'
    device     = 'RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller'
    class      = network
    subclass   = ethernet

Thanks a lot for the explaination.

I’m actually just running an SMB server hosting some backups and video files. TimeMachine from a MacOS computer sometimes runs a backup and sometimes I access the multimedia via SMB using Kodi.

The only reason I switched from a Raspi with 4GB to my small TrueNAS server was the fact that the Raspi didn’t seem ideal for running a 3,5" HDD drive together with another 2,5" drive. So there hopefully shouldn’t be any services that need more RAM than provided. (Answer to your memtest idea will of course still be provided.)

This Is kinda bad, think about tò switch on AN Intel dedicated nic

macOS has a history of pain with SMB. That might be a path worth investigating.

I don’t think it’s a NIC issue though.

It come back in my mind, when some time ago i have saturated the RAM amount, and the result was the same of the Op… In my case i have tried tò use a monitor and the Nas completely freezed (SMB and webgui not working too obv). As Always i think u right :joy:

1 Like

I have just been around here enough time to have seen most issues: sometimes I remember right, sometimes I remember wrong, often I don’t have a clue at all.

1 Like

Memtest passed without any errors

During the last days I found out, that I can reproduce the issue by copying larger amounts of data (5-40 GB) from the NAS to my computer. Same issue then: Disconnect and not possibility to access the server via network.

If RAM is OK and you are running no HBA, next suspect is indeed the NIC as pointed out by @oxyde.

1 Like

In my case, with Realtek NIC, the Nas reboot (not freeze), but at this point…

@nighty lucky you mainboard have a pci-ex 2.0 slot, you can try buy an Intel nic (15-20€), but in the memtest i see only 1 cycle in 17 minutes… Normally i load at least 4 cycle for be 100% sure…but as u pref

Thanks for the hint, will try later.

Also no error after letting it run for four cycles.
Intel NIC is on its way. Will report back after I installed it.

1 Like

I haven’t had time to conduct extensive tests, but if I don’t post further updates here, assume that installing a new network card resolved the issue.

For those interested, I purchased one with an Intel 82574L chip from 10Gtek for ~23 €.

Nearly forgot to say: Thanks so much for your help!


:partying_face: :partying_face: :partying_face: :partying_face: