iSCSI LUN limit?

we have create 7 LUN with different portal, when we create the LUN 8 (start from 1 to 8) the LUN 8 was not show on windows device.
if we change from LUN 8 to 0 the device apper
if we add a new device with LUN 8-9 10-16 etc not showd on windows.
the same disk with LUN upper 7 was not showed.

This is a my missconfiguration, it’s a limit of the trunas scale, it’s a BUG ?
Ver: 24.04.0

Seems like a Windows limitation to me.

When you say LUNs, do you mean all attached to the same Target? 8 LUNs in one target?

Workaround might be using additional target.

no, it’s 8 different server that each one access to theire portal.
we have create 8 portla, 8 target, 8 extend.
Each extend have lun from 0 to 8
we have 8 server each server are their extend and portal.
after LUN7 no any disk has been visible from the server.
we have create a new extent to the same target on the same server the disk was not show if have a lun >8
i found this issues:

that seem my issues, but also with LUN0 after the LUN7 the server not see the new disk,

i probabily found the problem.

windows basically support 8 LUNs, but if the hardware report the: HiSupport bit
windows automatically enable the support for Large LUNs number.

do you know if truenas support that?
is not raccomanded to edit it manually.

Hi @AlexSdav,

I believe there are a couple of things at play here.

First TrueNAS 24.04.* does have a limitation whereby it will not respond to a REPORT LUNs if no LUN 0 has been configured on a target. The fix for this has been pushed upstream, and will be available in forthcoming TrueNAS 24.10.* The workaround in the meantime is to always configure a LUN 0 for every target.

It is possible that an initiator (e.g. Windows, Linux) could have some fall-back code to handle this shortcoming, but IMO better to not rely upon it.

If you have 8 targets and 8 extents to serve one extent per target, then the extent should be configured at LUN 0 on each target.

TrueNAS does not currently set the HiSup bit, but it sounds like by renumbering your LUNs you won’t need it.

1 Like

Oh great, this is my fault.
i’m always work with MSA SAS storage, and with several TrueNAS as a VM that expose only 2 device, this is the first time we configure in this way and i think the LUN are globlally for the iSCSI not for single target.
Thanks a lot, we try today or tomorrow.

1 Like