iSCSI, MCS, and Windows

TrueNAS Core 13U6.1

I want to get MCS going/working in my playground/homelab just for fun. Facing trouble at the actual MCS part. Don’t assume I know anything, I have never done this before.

The above is the broad summary. This is a small part of some general screwing around I’ve been doing - namely, iSCSI booting Windows 10 over the network on some spare (old) commodity hardware I have laying around. I got Windows 10 installed and booting on my hardware. Slammed another NIC in the machine, configured it and the bridge on my TrueNAS inside a separate subnet (same L1/L2, don’t think that will matter just for screwing around, I know that isn’t how you’d do this “properly”). Tried to configure MCS by adding a connection inside the MCS “sub” window and … no dice. Get an error with the title bar text “Log On to Target” and error message “Too many Connections.”.

I think to myself - don’t panic, crawl don’t run, maybe this is Windows itself not wanting to tamper too much with the very target it is using to run. So I setup a totally different zvol, iSCSI target, extent, the works. Try to connect that all together in the same way, but I get the same error message.

When I look up that error, it implies that the target itself needs to support MCS, but I’d be somewhat surprised to learn if TrueNAS (Core) doesn’t support this. Can I get a definitive answer here? Nothing (helpful) came up when using a search engine. I briefly looked into MPIO but that doesn’t appear to exist within workstation SKUs of Windows - only server so that’s a dead end on this particular corner of my experimentation.

I’m hesitant to provide screenshots at this time as that would reveal some DNS-y things but I’m open to doing that, it would just require me to reconfigure some things.

P.S. Yes, the iSCSI service in TrueNAS is configured to listen on and I can connect to the iSCSI targets perfectly fine if I only use one NIC at a time.

Can you provide some screenshots with just like black boxes over anything you deem sensative data in like MS Paint?

Good point, got too deep in the weeds and might be forgetting the basics. :slight_smile:

I’ll return to this tomorrow and try to get some screenies.

Cool. A quick topology overview would be helpful too.
I did this in mermaid here on the forums with how mine’s setup right now, not an example to follow, but just how it is right now.

Discourse Mermaid - theme-component - Discourse Meta

If you ask ChatGPT or whatever AI assistant you might be using, it’ll convert plain English for you to “write” the mermaid syntax for you until you have time to learn it.

graph LR
    TrueNAS(TrueNAS<br><br>Target) -- VLAN 10 --> Nexus(Nexus<br>;
    Workstation(Workstation<br><br>Initiator) -- VLAN 10 --> Nexus;
    Nexus -- VLAN 10 --> Catalyst(Catalyst<br>;
    Catalyst -- VLAN 10 --> pfSense(pfSense<br>Router);

looks like this, but with mermaid next to the tick marks

    TrueNAS(TrueNAS<br><br>Target) -- VLAN 10 --> Nexus(Nexus<br>;
    Workstation(Workstation<br><br>Initiator) -- VLAN 10 --> Nexus;
    Nexus -- VLAN 10 --> Catalyst(Catalyst<br>;
    Catalyst -- VLAN 10 --> pfSense(pfSense<br>Router);

EDIT: HA it broke please hold

AI is still funny, Look at all the pitfalls I fell in

I don’t think I’m going to be working on this exact setup very much if there’s not an obvious answer/mis-step I’m making that someone can point out. More likely I’ll just shift to trying to do this same thing using MPIO in Windows Server to remove a few variables. That disclaimer aside, a very basic diagram and screenshots of the interface:

Mid-post correction: Diagram will come in the next post due to 5-image limit.

The one thing that confuses me in the workflow above is precisely what a “Target portal” is in this context and why if I add the other IP manually ( it never shows up in the drop-down. Maybe that’s a symptom of the iSCSI boot. I have no idea.

And yes, I’ve tried doing effectively the “inverse”, and I’ve tried disconnecting and re-connecting the target including the “Enable multi-path” checkbox, and a whole bunch of other ideas. All permutations I was able to come up with/tried resulted in the same error message.

My money is on this being a limitation in Windows Home edition (wouldn’t be surprised in the least) or something I’m doing wrong. I can’t imagine networking being the problem here, pings work fine and as you can see from the diagram - this is a very simple setup.


The bridge on the TrueNAS core system is only connected to one physical/real NIC. The bridge only exists to allow the operation/needs of a VM.