Issue with Docker Hub 429 Request limit

Hi everyone and happy Friday,

Today when I hit the update all button for around 8 dockers, after 5 I started getting the 429-response error indicating the rate limit was hit (Understanding Your Docker Hub Rate Limit | Docker). Very weird so I reached out to docker hub. They confirmed that my IP violated the rate limit. Anyone know why this happened? 5 containers seem very short of 100 in 6 hours :slight_smile:

How many layers do they have? Those all count, as I understand it.

Sidenote: Back when they started doing this, I noticed that their accounting is sometimes wildly inaccurate. Hasn’t happened to me in a long while, though.

1 Like


I run a docker-mirror.

The docker-mirror is configured to login via my free docker hub account, that increases the limit.

My docker sandbox is then configured to use the mirror (via daemon.json)

1 Like

Thats a cool idea. Do you know if TrueNAS is thinking about supporting this as a feature, so this additional layer isn’t needed for updating?

Yeah, I’m thinking this is the case. The person that emailed me back is pushing me hard to buy an account. I tried to explain to them that wouldn’t fix my problem.

It doesn’t really do that much for you, unless you’re hosting for multiple systems…

yeah, other than allowing you to have an authenticated session with docker hub. I’m judging the value of 100 vs 200 image pulls and the effort involved.

I am seeing the same problem here. Even updating just a single app takes a long time because of the docker rate limit. It seems Scale just does anonymous pulls and I suspect that since my ISP has a CgNAT my apparent IP address is shared by thousands of people.

How is this supposed to work?

I think it does do anonymous pulls, which is why the limit is lower. Even a free account logged in has a higher limit. It would be awesome if there was a way to log into your docker account to increase the rate limit.