Issues Setting Up Wireguard - Interface Does Not Exist

Hi all,

I’m trying to set up a VPN to get remote access to my TrueNAS Core server and I’m finding it very difficult to work out what I’m meant to be doing. I’m following these instructions but it all falls down at the last hurdle: Enabling WireGuard | TrueNAS Documentation Hub

Using ifconfig wg0, I just get ‘interface wg0 does not exist’. I tried rebooting and the same. Using wg-quick wg0 also returned ‘wg0.conf does not exist’ I navigated to /usr/local/etc/wireguard and there is no wg0.conf file so I tried created a blank document and ran wg-quick wg0 again. After then running ifconfig wg0 again I got a readout though it was missing the lines beginning inet and nd6 options as shown in the documentation.

I thought maybe now was when I needed to reboot but when I did, ifconfig wg0 returns ‘interface wg0 does not exist’ again and navigating to /usr/local/etc/wireguard shows that wg0.conf has been removed so I must be doing something quite wrong.

I’m finding it hard to find any tutorials for setting this up in TrueNAS Core. Everything else is for Scale which seems to have a GUI or Linux where the instructions are different enough that I can’t work out what information I need to get and what I need to do with it to set it up here.

I may give up on this and just follow the guides that I have been able to find about setting up Tailscale in a jail instead but I didn’t want to be beaten! My main aims with this are to remotely access the contents of my NAS as well as access plugins that have a web UI like QBittorrent.

Thanks in advance for any help!

You should specifiy Hardware and software in these requests.

Then help by providing diagnostics.

e. g what does this screen look like?

My server is running TrueNAS Core 13.0-U6.1 and the system specs are:

CPU: Intel i5 7500
Motherboard: Asus PRIME B250M-A
RAM: Corsair Vengeance LPX 16 GB (4 x 4 GB) DDR4-2133 CL15
NIC: Edimax 2.5Gb NIC
OS Drive: Gigabyte 256GB NVME
Storage: 5x 8TB WD Blue in RAID Z1

And this is what the Tuneables page looks like:

What if you try loading the WG config directly, without first copying to the temporal directory?

wg-quick up /root/wg0.conf

This assumes your WireGuard config file is under/root/

I was stuck tryng to set up a VPN with built in openvpn, then i follow this well explained guide

Maybe you can give a try too