Jails not working on TrueNAS Core

Recently my JAIL drive somehow filled to 100% usage and all my jails then crashed and they will not load at all. It shows they are started and running but they simply don’t load at all when trying to access them by the browser.

I tried restarting the jails. I tried rebooting the system. I tried powering down the system and leaving it unplugged overnight. I tried rolling back one of the jails to a snapshot from a few months ago and nothing worked so far.

Any help getting my jails back up and running would greatly be appreciated.

installed a brand new plugin/jail and it worked perfectly fine, going to try and maybe install another copy of the jail and see if i can clone the data over and it’ll work

Version: TrueNAS-13.0-U6.1

Attached are some images.


With that being said I also have a 2TB drive on order that will be arriving soon and wanted to migrate all the data from the 1TB jail drive to the new 2TB jail drive is we can get these jails back up and working.

Have u try to enter in the shell of one running jail, and check the connection?
Maybe is just a network problem!

Can you log into any of the jails?

I have not tried any network stuff i can login to the truenas gui and a newly made jail works fine just the old ones not working

I am out rn will be back home in an hour or two and i can check

I can login to the jails through the shell no problem.

Not experienced in network stuff or freebsd at all but did a ping google.com from the jail shell and it looks good

root@thestash:~ # ping google.com
PING google.com ( 56 data bytes
64 bytes from icmp_seq=0 ttl=59 time=30.059 ms
64 bytes from icmp_seq=1 ttl=59 time=30.357 ms
64 bytes from icmp_seq=2 ttl=59 time=30.613 ms
64 bytes from icmp_seq=3 ttl=59 time=30.081 ms
64 bytes from icmp_seq=4 ttl=59 time=31.350 ms
64 bytes from icmp_seq=5 ttl=59 time=29.556 ms
64 bytes from icmp_seq=6 ttl=59 time=29.775 ms
64 bytes from icmp_seq=7 ttl=59 time=31.190 ms
64 bytes from icmp_seq=8 ttl=59 time=29.868 ms
64 bytes from icmp_seq=9 ttl=59 time=36.984 ms
64 bytes from icmp_seq=10 ttl=59 time=30.050 ms
64 bytes from icmp_seq=11 ttl=59 time=30.820 ms
64 bytes from icmp_seq=12 ttl=59 time=31.560 ms
64 bytes from icmp_seq=13 ttl=59 time=30.299 ms
64 bytes from icmp_seq=14 ttl=59 time=30.088 ms
64 bytes from icmp_seq=15 ttl=59 time=30.056 ms
64 bytes from icmp_seq=16 ttl=59 time=30.334 ms
64 bytes from icmp_seq=17 ttl=59 time=30.177 ms
64 bytes from icmp_seq=18 ttl=59 time=34.162 ms
64 bytes from icmp_seq=19 ttl=59 time=30.715 ms
64 bytes from icmp_seq=20 ttl=59 time=29.966 ms
64 bytes from icmp_seq=21 ttl=59 time=30.334 ms
64 bytes from icmp_seq=22 ttl=59 time=29.354 ms
64 bytes from icmp_seq=23 ttl=59 time=32.156 ms
64 bytes from icmp_seq=24 ttl=59 time=29.666 ms
64 bytes from icmp_seq=25 ttl=59 time=33.082 ms
64 bytes from icmp_seq=26 ttl=59 time=35.279 ms
64 bytes from icmp_seq=27 ttl=59 time=30.286 ms
64 bytes from icmp_seq=28 ttl=59 time=31.301 ms
64 bytes from icmp_seq=29 ttl=59 time=30.923 ms
64 bytes from icmp_seq=30 ttl=59 time=31.485 ms
64 bytes from icmp_seq=31 ttl=59 time=31.799 ms
64 bytes from icmp_seq=32 ttl=59 time=32.056 ms
64 bytes from icmp_seq=33 ttl=59 time=29.285 ms
64 bytes from icmp_seq=34 ttl=59 time=30.058 ms
64 bytes from icmp_seq=35 ttl=59 time=30.197 ms
64 bytes from icmp_seq=36 ttl=59 time=31.400 ms
64 bytes from icmp_seq=37 ttl=59 time=29.407 ms
64 bytes from icmp_seq=38 ttl=59 time=30.396 ms
64 bytes from icmp_seq=39 ttl=59 time=30.520 ms

In this particular jail, what are the contents of:

cat /etc/rc.conf

That’s it? So there are no services configured to start automatically with the jail?

What is this jail? What is supposed to start automatically? Are you using a non-service autostart script?

trueness core community plugin “Transmission”, it just worked when installing the plugin till the jail drive was maxed out and all the jails stopped working, I was able to empty most the jail drive by deleting snapshots prior to 2024

You shouldn’t be using “Plugins”. They are unsupported and deprecated.

But in the meantime, we can try to see if Transmission’s daemon will/can start.

First, check if the service is running:

service transmission onestatus

If not, try to manually start it:

service transmission onestart

Now does it show it is running?

service transmission onestatus

If so, try connecting to the web GUI via your web browser.

yeah it’s an old setup from like 2017-2018 everything is always running smooth till something weird happens like the jail drive being maxed out from snapshots

You fixed the problem with this jail, going to check the other ones

it looks like i am going to have to add the jailname_enable=“YES” to the /etc/rc.conf files

Not “jailname”, but “servicename”.

In this case, the service is named transmission

is there a way to list services to enable in a jail? like say there are 6 things that were running in a jail but i only know the service name for four is there a way to find the other names?

You can check under /usr/local/etc/rc.d/ for a list of “non base system” services, which were likely installed upon installing packages from the repository.

I did the following below and now the jail just won’t start up at all even after a system reboot

nano /etc/rc.conf

cron_flags="$cron_flags -J 15"

# Network

# Disable Sendmail by default

# Run secure syslog
syslogd_flags="-c -ss"

# Enable IPv6

# Transmission

# OpenVPN

What does this show?

From the host command-line:

iocage start transmission

syntax error forgot a " and it failed it from starting was able to nano into it and fix it

Going to mark this thread and solved. I am not sure why the rc.conf file was wiped on all the installed jails though. Going to have to just rebuild each. I will set up some sort of snapshot for it or something to rollback to in the future if this happens again.

I can’t post anymore have to wait 18 hours for next post

I am able to get 5/6 jails up and running flaresolvarr is the last one that I just can’t seem to get back up and running.

That is possible but flaresolvarr isn’t a plugin jail it’s a manual one and also lost it’s rc.conf info

1 Like

Not sure either. But if these were Basejails that you created (without using “Plugins”), then they would be maintained and updated as you would any FreeBSD system. Perhaps something borked with the Plugins?