Keep receiving "Hadupdate" error, what is it?

Since moving from Dragonfish beta to full release, ive been getting a critical error stating cannot hadupdate?? It seems to clear itself several hours later, but given its flagged as critical id like to know what it is, and whether i should be finding a solution. Anyone else getting this since the april update?

Edit, nvm, solved second error, still not sure what a hadupdate is though

I believe HadUpdate is TrueNAS attempting to phone-home that its been updated.

If internet access is not functional at startup it can fail. but it retries every hour and should stop once it succeeds.


1 Like

Oh geez, barely critical is it!! Havent IX heard of the boy that cried wolf haha anyways cheers for the help @Stux , its probably my dodge connection, getting fibre in few days so no worries

In my case it fails because I use a virtualized router, and the router hasn’t started up yet when the HadUpdate check is run the first time :wink:

1 Like

Same for me (although in my case it’s a DoH Relay + PiHole so it can’t resolve the domain)… definitely doesn’t seem critical, maybe a delay should be put in on first-boot update checking to allow for this sort of use-case without freaking new users out :laughing: .

Edit: OR! Perhaps lowering the severity of the non-critical critical alert

1 Like