Link Aggregation - no luck adding

Trying to reestablish Link Aggregation, which worked fine on my CORE 13.0-U6.1, but can’t get it to work. on my upgrade to SCALE Dragonfish-24.04.0. This is my interfaces, one on-board and one PCI:

And their individual setup:

When trying to setup Link Aggregation, none of the interfaces show up:

Also tried using TrueNAS CLI. But no luck.
Any suggestions?

Well right off I see you have not picked any interfaces in the Add interface setup so the setup does not know what network ports you want to use. You also have to add aliases to each interface which is not shown in your add interface image so I cannot tell if that is configured in order for the aggregate to be setup. There is a new video out from @Stux (I think) that goes over proper configuration of networks on Truenas. You should check it out.

Never played around with LAG in TrueNAS but it strikes me as odd that you would define the discrete interfaces as you have in the two first screenshots and then try to use the same now already used interfaces to setup the LAG. Isn’t it one or the other?

That would explain why you have no interfaces to choose from in your LAG-picture, they are claimed. The reasonable solution is to remove the discrete interfaces so they can be used in a LAG instead.

Edit: Although, your second interface does look unconfigured, I would have thought at least that interface would show up in the list of possible LAG members.


I believe once the LAGG is setup, tested, and saved correctly, the ports will no longer show anything and won’t be setup as such (they are part of the LAGG interface now). Both ports need to be selected and also I believe need to be setup with aliases (static ip addresses) under the LAGG setup. that is so the LAGG can bond the two ports.

I did the network interface setup from CLI (GUI stopped responding, when activating added LAGG) where the bond30 (including both NICs) is accepted and Truenas shows me the correct web user interface address :partying_face:.

But when I try to connect to TrueNAS from a client, the connection times out (ERR_CONNECTION_TIMED_OUT) :exploding_head:.

I ran into this a couple days ago. Linux (PoPOS) was able to access SMB shares just fine using the name system1.local, but windows refused to even though windows access was working just fine before the change from a single ethernet connection to setting up the LAG connection.

I found the Dragonfish system kept the old static IP of the first network port after I setup the LAG. I had to enter the IP address of the LAG in order to access the GUI from any windows computer as they all refused to find the system by the domain name of system1.local.

I verified on a windows machine that the server was indeed still bound to the old static address when accessed from windows using the following command from a powershell command prompt run as administrator:

Test-NetConnection -ComputerName truenas.lan -CommonTCPPort SMB
Change truenas.lan to the domain name of the server If the commmand fails then try with the LAG IP address as the name.

If the command runs successfully using the domain name then all should be good, but if it fails and shows it tried to ping with the old ehternet ip address then You have an issue to track down.
I ran

arp -a

on the Truenas system and found the ARP Table was not flushed of the old IP address.
I ran arp -d “offending-ip-address” to remove the address from the ARP table. While this did not seem to fully cure the issue, ARP was then populated by a IPV6 address on the windows computers which workes fine.

To note the system was available in windows by the ip LAG address if mapping shares or access by ssh.

I´m using the same IP as I used on the CORE (no DHCP), so even if the static IP is transferred to the upgrade, it’s identical. But when choosing the 2 interfaces, which I managed to do, by resetting both interfaces before adding the LAGG, I then cannot connect to NAS, even though NAS web interface is showing the correct address in the CLI :thinking: