Logitech media server not recognizing players

So i installed the lms or logitech media server truecharts app. Its deploying and finding my media files just fine. The problem is that it cant find players on the network. ive added dlna upnp plugins and noticed that they are not working because no config file is created. This might be an acl problem, i think.

Did anyone get the truecharts version working and are there any other options?

tnx in advance

OK, so to continue our conversation over at the old forum, this is how I’ve set it up:

  • for both the app data dataset and the music files dataset, in the ACL edit sheet the owner and the owner group are my separately set up LMS user (passwordless, member of the primary group “apps”) and the “apps” group.
  • I’ve add the items for this user and its group (with “modify” rights for the app data dataset and “read” for the music dataset).
  • I used the official docker hub image (lmscommunity/logitechmediaserver) to set up a custom app. This is very easy, just set up your container environment variables for PUID and PGID, as well as the time zone (TZ), add your host path volumes (make music read-only).

That’s about it I think…

I have installed and running TrueCharts Logitech-Media-Server.

For the remote player connection (for me a piCorePlayer), I don’t recall doing anything special to get it to see the new server - but that was a few weeks ago. Looking over the app configs, nothing stands out.

PM me, perhaps we can compare configs, etc. to see if we can narrow down where it is going wrong for you.

PS I used to run LMS for many years in a jail on Truenas core.

For me the non-TrueCharts image works flawlessly on SCALE, but I’m curious what you guys find out…

(Can you perhaps keep it on the forum instead of PM’s so maybe I can learn something, as my install can be even improved upon, maybe…)

In the interest of sharing while looking deeper at my working setup:

  • my LMS app is using not using an external network interface, so it has the same IP address as my TrueNAS Scale server (
  • Some other apps are using external network interfaces, but I don’t believe that has any impact on the LMS app instance.
  • LMS uses network ports 9090, 9000 and 3483 TCP, and 3483 UDP (according to the app. Testing for TCP connections from my laptop, I am able to connect. I’m not sure how to test UDP port 3483 :frowning:
  • My network is flat inside the firewall, My laptop, piCorePlayer, LMS/TrueNAS Scale (+ many other apps) server are all on that subnet.

Testing network connectivity from my laptop, I see the below. If any of these tests are not working for you, then something in the networking to look into (firewall, routing path, etc.).

peter@Peters-Air-M1 ~ % nc -vz 9090
Connection to port 9090 [tcp/websm] succeeded!
peter@Peters-Air-M1 ~ % nc -vz 9000
Connection to port 9000 [tcp/cslistener] succeeded!
peter@Peters-Air-M1 ~ % nc -vz 3483
Connection to port 3483 [tcp/slim-devices] succeeded!

For some other apps that I’ve been learning (and debugging my setup), heavyscript does let me see the LMS logs from inside the k3s pod. Looks OK on my system, you should make sure this is error free for you:

$ /root/bin/heavyscript pod -l logitech-media-server
How many lines of logs do you want to display? (Default is 500, “-1” for all):
Starting Logitech Media Server on port 9000…
[24-05-13 20:45:49.9018] main::init (386) Starting Logitech Media Server (v8.5.2, 1715497664, Mon May 13 04:13:00 CEST 2024) perl 5.032001 - x86_64-linux-gnu-thread-multi

If I recall correctly, my biggest issue during the migration from LMS as a jail on TrueNAS Core to apps on TrueNAS Scale was folder and file ownerships on the ZFS storage for the music files. File/dir ownership and permissions were a bit of a mess and the new TrueNAS CORE apps didn’t like them (file passthrough). A quickish chown -R apps:apps /music/path fixed that up. May have also had to do a chmod -R 700 as well.

tnx guys, later today i will test it and look at the difference in configs.

Ok so i checked the settings of lms

So the datapool (freepooljoost) with my music is owned bij root and my own user and user group (joost)
The datapool for lms is software joost and has two folders. One is the ix applications and one is the configs
Now the lms folder has the following users

i added apps to the user group joost
The ix applications folder is only root acces (user and group). i cant change that.

so Lms is connected to the music folder. Just the players i dont see and like i said the plugins are not able to make a config file. In my assumption, the config file is in the lms folder which has the same user and group (joost) is dataset with the music files.

Because your LMS cannot see any players, I’m thinking there is something wrong on the networking side.

Note, I did need to “inform” my player of the LMS IP address. Not sure on your player that would work… something worth looking into. Somewhere in settings on the player I would suspect.


How does your Services section for the LMS app look?

Here is mine (it is a long section, so 3 images to get it all):

Are you able to try these network commands from another linux box to see if the network ports are accessible?

$ nc -vz {LMS_IP_ADDRESS} 9090
$ nc -vz {LMS_IP_ADDRESS} 9000
$ nc -vz {LMS_IP_ADDRESS} 3483

Each of the above three commands should return “succeeded” when run from another linux/mac box.

the services look like this

So i tried the command and i get : Couldnt resolve host

btw im also using picore. Besides picore i have a few sonos devices that i connect through the dlna plugin. At least the picore should be visible

ok so a succes. im able to find the picore player bij manually adding the server adres in picore to lms on the truenas. now the next step to get the plugin upnp bridge to work and to get squeezelite recognised

there is something not right …domain not set

i have not been able to access any other players then picore. squeezelite is not recognised.

Add your server address in Squeezelite etc it is usually a -s option in advanced options. the base O/S does not forward the player broadcast queries otherwise.

ok tnx i will try that

that seems to work for squeezelite! i got i running by running:

so now i have two players running. Now for the last part is the sonos players trough upnp plugin. Since this is (i think a different problem) should i mark this question as resolved? still think it is strange that i manually have to add the server. Never had to do this before.

i also managed to get the upnp plugin working…so all devices are working

my truenas settings

The app needed host settings under global pod options

I just had to reinstall my piCorePlayer (SD card died on the Raspberry Pi). When I re-installed piCorePlayer on a new SD card, squeezelite on the piCorePlayer was able to find the LMS server (when the IP address is configured in squeezelite), but JiveLite could not. How I managed to get it working before, I’ll never know.

Turns out the Truecharts version of the LMS app is missing a port: 1069. This is used for LMS autodiscovery.

I tried adding port 1069/udp to the LMS (helm chart?), but I was unsuccessful. Instead, I put the LMS app on it’s own IP address (so it is not using the k3s LoadBalancer), and that fixed things for me. I assume this makes port 1069, along with any other needed LMS network ports, available to players. Now the piCorePlayer squeezelite does not need to be told the IP address of the LMS server, and JiveLite was also able to find the LMS.

Turns out LMS discovery only works if the client/player and the LMS are on the same LAN/VLAN since it uses broadcasts.

Hints needed for LMS with players connected to a separate VLAN

interesting, how did you change from loadbalancer to its own ip adres?

after installing other plugins …dynamic playlist, cast the players were gone. have not been able to get the upnp plugin to work again

interesting, how did you change from loadbalancer to its own ip adres?