Looking for a Reliable 1Gb NIC

I saw that review but it’s not for the same model, it’s for an x520 based card. Unfortunately I don’t have another machine that I can install this card in.

I’m out of ideas. Only other thing I can think of is trying another OS. Live Linux boot and see if it picks up the Intel card, dhcp and link?

So I actually ordered 2 different NICs. I also ordered the 2-Port NIC in the Amazon link that @dan posted earlier in this thread.

I just installed that and I’m getting the exact same results. 2 interfaces appear in the Web UI (em0 and em1) I set em0 for DHCP, on boot my router assigns it an IP (this time .92) but I can’t connect and can’t ping the router from the console.

Two completely different NICs, with completely different chip sets from completely different manufacturers having the exact same connection issues. I don’t think it’s a problem with the NIC.

Does anyone else have any suggestions here?
So far I’ve bought 2 new NICs and I’m right where I started with using the flaky Realtek port on the mobo.

Maybe the title isn’t getting you views. You can try a new post with a title (trouble changing from realtek to intel nic ??) and just post a link to this thread

Lets skip doing anything at all on the WebUI. I think something is getting confused because you have an active connection on an interface thats statically defined, and you’re trying to move to an interface that is in the same subnet. Using DHCP here is also muddying the waters.

Unplug network cables going to the realtek ethernet card. On the local console, select 1 for Configured Network Interfaces then select the re0 interface. When it asks you to delete the interface, select Y. Repeat for igb0.

Now, go back into igb0 and statically define the IP and netmask /24. Do not use DHCP. Apply and persist that change, then go back to the main screen with all of the options. Select 9 for shell. Ping You should get replies now. Type exit which will bring you back to the main screen.

Then select Option 4 to set the default route and then Option 6 to set the DNS you’d like to use, and you should be all set to log back into the WebUI.


Good points. Making network changes with the web UI always has room for error followed by disconnects whereas the console is here to stay.

I found that out the hard way when I tried to install a a failover LAGG, which simply failed spectacularly. Nuking everything and restarting from scratch via the console made quicker work of fixing the mess.

There are a lot of terms in the ifconfig status output that can also be confusing to a n00b like me.

Thank you Nick! This worked and I am not running my TrueNAS setup from the i350 card!


This is why command line will always be around! Cause even basics stuff in UI’s can still be flakey and annoying.