Looking for a Reliable 1Gb NIC

I’ve had a system that was originally FreeNAS and upgrade to TrueNAS for many years now with very few problems. Recently I upgraded the storage from 8TB to 32TB and have started using it more heavily. Everything seems to work great except for the Ethernet connection.

I’m using the port on the mobo which is Realtek. and what happens is if I start doing a lot of heavy transfers eventually the port will just stop working. Generally it will work fine for hours or even days but then it will just stop functioning as if I’ve physically unplugged it and I can’t communicate with my NAS anymore over the network. Using a monitor and keyboard on the system itself there’s no indication of any problem, and the only way to fix it seems to be to reboot.

I’ve been reading that Realtek hardware is not recommended and Intel is, but I’ve spent several days just trying to find a recommendation for a simple 1Gb NIC that I can run but all I find are lots and lots of discussions about 10Gb setups, fiber, or people having issues that never seem to be resolved.

So two questions:

  1. is the problem I’m experiencing fixable by upgrading my NIC
  2. is there a specific 1Gb NIC or even a specific Chipset that is known to be bulletproof with TrueNAS?


Simply an Intel Gigabit NIC, the Pro/1000 is a good choice. Like this one:

Or this:


Perfect. Thanks!

Those are very old. The one in ebay is a pci nic if I see right, which won’t plug in your system.

Get an intel or oem card based on the i350 chip. There are many variants with 4 ports (i350-t4) for about $30 on ebay.


I found this dual port NIC that worked in mine very well. I would keep the other port for Management only.

1 Like

Good point, and kind of an obvious thing for me to have overlooked. The Amazon one is still OK. Or, as you say, an i350-based card.

What model is the card in the Amazon link? how can you tell what chip set it uses? even cross referencing the UPCs lists only really turns up the Amazon listing page.

I’d recommend the i350 as well, the i2XX chipsets can have trouble with tcp offloading when using VMs, necessitating disabling features with an ethtool command post-init.

Better to get the i350 if possible (which also support SR-IOV, but I think that can’t be used in TrueNAS anyway)

1 Like

Thanks all, based on the recommendations here I’ve opted to buy this i350-t4 based card: Amazon.com: 4 Port Gigabit NIC for Intel I350-T4 with Low Profile, Gigabit Ethernet Network Adapter Card with Intel I350-AM4 Controller, Support Windows/XP/Linux/VMware ESX/ESXi*, Quad RJ45 Ports, PCI-E 2.1 X4 : Electronics I’ll report back once I’ve got it installed and running for a bit.


Not too much to worry about. I have an i350-t4 myself and it is pretty much an uneventful installation. Normally just works.


So, I got the new card in a couple of days ago but I cannot for the life of me get it working. the new interfaces are all recognized in the Web UI but I cannot access the Web UI or any of the share from any of the ports on the card.

I’ll setup a port for DHCP, on boot I see on the screen that it’s been assigned an IP and claims that the web UI is available at, I see the LEDs on and my router flashing showing activity. But my browser acts as if there is no web-server at that address and I can’t access any of the shares at that address either. I’ve tried all 4 of the new ports. The on-board Realtek port still works just fine though.

I feel as though I’m missing a critical step in setting this up.

Are you still on Core? If so, if you access the GUI through the RLT NIC, can you see the new NIC ports in the network section?

yes I’m on Core. and yes if I access the GUI through the RTL NIC I can see the new NIC ports in the network section.

Seems like you have a static configuration on the RTL. Is it possible that this prevents you from selecting another interface?

No, even if I remove that and set igb0 to static instead I can’t access the web UI. I’ve tried that, I’ve tried putting them on different sub nets, I’ve tried disabling re0 completely, I’ve tried link aggregation in several different configurations.

I’m on day 3 of trying different configurations here and not one of them has allowed me to connect to the box through the new NIC. I feel like I’m missing a setting somewhere that sets the NIC priority for the web UI or something.

Are you putting both the re0 and the igb on the same subnet at the same time?
“I’ll setup a port for DHCP, on boot I see on the screen that it’s been assigned an IP and claims that the web UI is available at, I see the LEDs on and my router flashing showing activity” and your above screenshot shows re0 at

I guess write the exact steps you are taking. Try to mention everything you are doing, changes, reboots, etc. Do you have access to the TrueNAS console. I am also wondering how you physically have it plugged in.

Here an example of an attempt I’ve made:

  1. I went into Interfaces Page of the Web UI
  2. I disabled the static IP of re0, disabled DHCP on re0
  3. I enabled DHCP on igb0
  4. I saved the network configuration
  5. I powered off the server
  6. I physically removed the CAT6 cable from the re0 port and plugged it into the igb0 port on the new NIC
  7. I powered on the server
  8. after booting the server console reported “the web user interface is at
  9. I observed LED activity on the igb0 port, I observed LED activity on the router port that igb0 is connected to
  10. I accessed my routers DHCP page and confirmed that it assigned to the MAC address that matches that of igb0 (per the physical sticker on the card)
  11. Multiple attempts to access the Web UI on my PC at timed out with server not found.
  12. Multiple attempts to access SMB shares on failed to connect

After this failed attempt I had to reconfigure the ports through the console interface to re-enable re0 so that I could access the Web UI again.

I’ve repeated this process about a dozen times with steps 2 and 3 changed for different configurations in an attempt to find one that is successful.

If there’s something here I’m doing wrong or missing please let me know.

That all looks like it should work.
If you go to the console after bringing up igb0 and everything, does the command ifconfig show the correct and matching info? What happens of you try to ping the router address from the console?

Trying to sort out if you are able to talk to router while on igb0. I don’t expect the router info nor nameserver address to change between the two network interfaces. Also trying to confirm re0 is down and has no address associated when we expect igb0 to work.

setting up igb0, ifconfig looks normal:

but weirdly I can’t ping the router:

This despite the fact that I can go into my router and confirm that the .41 IP is actively being leased to the correct MAC Address

phoenix 98:b7:85:1f:f5:08 23:50:25

I looked at the amazon link you had above and there were a few bad reviews with the same issue. Maybe try the card in a different computer if possible? Maybe the card and manufacturer is a dud?