Lost data? Have backups and snapshots. Need help

Hello all,

I have a SMB share to my Windows 11 desktop. When I access the network drive I do not see all my data. I have missing folders and what seems like several hundred gigabytes just not in the directory. I noticed this defect yesterday and everything was fine a few days prior to that.

The weird thing is I am connected to the same directory on my Android phone, iPad, and other devices, and I can see everything just fine on there.

I do have snapshots and an offline backup so if all else fails here I can just restore. (Not sure the best way to do that either) But, does anyone have any insights on what I should do here? I am a noob at TrueNAS still, but any help would be greatly appreciated!

Motherboard: Supermicro X11SSM-F
CPU: Intel Pentium G4560
RAM: Nemix MEM-DR416L-CL01-EU21
PSU: Corsair RM850
Boot SATA SSD 1: Lexar NS100 128gb
Pool 1: 2-way mirror; 10tb (Model Number: HUH721010ALE601)

Update: I restarted my local TrueNAS system and it seems to have fixed the issue? I really don’t know how? If anyone has any insights on why it would suddenly remove from viewing a bunch of random folders from my system on 1 select SMB share please let me know so I can change any settings if need be.

I reset the system at the local terminal console by accidently pressing ctrl alt del in an effort to escape a command I hit in early. Not sure if that’s bad either. But, if I run into further issues later because of this I will update here again!

How is your ACL set up?

So that would indicate your data is not gone, right? Why don’t you check through the shell if it is in your pool(s). This might be a Windows issue.

So that would indicate your data is not gone, right?

  • Yes that would seem to be the case. I posted an update more up in the thread saying I restarted the TrueNAS system and that seems to have fixed it on the windows system.

I am not sure what "check through the shell if it is in your pools means. I am a novice at this software.

I agree this may be a windows being dumb issue. But, I would like to know atleast roughly what may have caused it if possible so as to prevent this issue from happening again in the future

ACL is set up like this

If I have screenshotted the correct info, here is an attached image of the permissions menu. I followed the same system settings as promoted by lawrence systems in this video linked below: