Making truenas scale shares visible to windows

Hello there

As my previous post, i really fobard my home lap (if you want to call it this way)

It all started with me creating RSYNC or replication tasks (which is still)
I login to my freenas server as admin
all my shares have me as owner of the datasets
my windows (10 and 11) are configured properly
my smb service is configured with workgroup = home
smb1 and ntlm1 are checked
My windows networks and sharing settings are correctly configured

Until yesterday evening all was working well

how did i screw thing up and how di i correct then

By the same token how do i simplify my environment (namely ACL setting)

Thank you all for you patience in this matter

If I didn’t miss anything you did not specify the actual problem?

Try mapping the share with \\your-truenas-ip\sharename if the network discovery doesn’t work.

Thank you for your reply

I tried your suggestion to no avail

For your information I also did all of the ipconfig and netsh commands that i normally had to do again to no success.

I can however see all my videos and listening to audio through jellyfin

I am stumped

@ chuck32

All my datasets that i share have the same permissions no ACL. They only have permissions set

We need information.

Show a screenshot of your share, the name you will need to use is the one set in samba under “name”.

What error message do you receive?


thank you for your patience and your help

I see the server in windows explorer and when i click on it i get an error 0X80070035.

I googled this error to ensure i did not miss anything and i followed all their re=quirements

hope this helps

I wounder if the is a problem that was cause between the update of win 10 and 11 and the latest update of truenas.

I read that truenas will deprecate smb1.

I have 3 pcs running win 10 and 11 and 3 more running win 7

I tried stripping all ACLs to no avail and I checked again (3 times) to fix error 0x80070035 as per youtube and google search

thank you

Maybe it’s me who’s doing it wrong, but I don’t get why so many people change the owner of the datasets. Just leave them at root and root for user and group and manage everything else with the ACL.

Since you said it just stopped working without any interference my bet is still on the network discovery not working. SMB shares in windows are not as reliable to setup in my experience and the network discovery is another can of worms…

You said you updated but you still described the problem as if it just stopped working overnight. Any changes prior to it stopping working?

When you make changes to the filesystem ACL make it recursively. Otherwise it will not carry over to your existing files.

Let’s see, you are using the credentials for wbravin in windows?

If so, it seems like you share ACL and filesystem ACL are set correctly. You could activate the inherit flag too. Personally I have the share at the default everyone@ and just set filesystem permissions, but I don’t care if anyone can see the shares or not.

  1. Go to credential manager in windows, and delete the entries for windows credentials that are used for your SMB shares.
  2. Unmap your exisiting shares (if they are mapped)
  3. Reboot just in case


  1. Go to your truenasGUI, in the Shares tab take not of the share name

  1. In windows, open the explorer, right click This PC and choose either map network drive or add network location.

  2. Enter: \\\media ← modify according to your IP and the name you found earlier.

  3. Now you will be asked for your credentials, enter wbravin and your password

In theory this should work.

If it doesn’t apply permissions recursively in filesystem ACL.

Per my knowledge it should deprecated already in truenas and isn’t activated in windows per default anyway.


You can leave SMB1 support disabled, windows doesn’t need it:

In your SMB Share at least these boxes are ticked?

1 Like

That’s terrible, datasets should be owned by a relatively reasonable user (say an admin user), who can then configure ACLs via Windows. Sure, it’s less terrible ever since TrueNAS got its minimal ACL editor, but it still feels wrong for root to be the owner.

1 Like

Hi all

guess what… we just had a power failure and the whole town went dark.

after 10 minutes the lights came on and i restarted the servers and then all worked fine.

i spent 2 whole days working at this re starting the server several times with no results .

yet the power failure fixed everything

go figure

just the same thank you all for your patience understanding and help

Glad I’m asked and thanks for your answer.

And then using the admin account to access the share in windows?

Is this purely speaking from a convenience standpoint? My reasoning was that me / the admin supplies the server, configuration etc. and the windows users just use it. But I also only supply two machined with SMB shares and didn’t feel the need to be able to adjust permissions in windows. Although this probably gives a more fine-grained control method.
When managing everything in truenas GUI I can also just use user profiles without any additional privileges to access the shares.

For management, anyway.

Sorry if I’m dense, so you occasionally connect using admin credentials to make changes but have the shares mapped with a local user account, non admin?

If there’s no apparent downside to my approach other than the management I’ll probably stick to it, but will refrain from recommending it around here :slight_smile:

It depends on the specific situation, but in broad strokes, yeah.

Hello all sorry to be a pain.



Ferver 1 (Truenas) is working fine thanks to all your help

however i’m having issues with second server (Freenas2) (also a truenas server that i use for backups)

I did take onboard All your recommendations and they made me look at my whole

I did find some issues on my system that i corrected relating to truenas scale credential setting, which i corrected Group member of root, wbravin,admin and wheel.

I can map the drive to my PC (all my Pcs) and access al the relative data.

I finally looked at the share services setting and realised that netbios name was wrong. It showed truenas

I never looked at this because when i initially configured the server I changed the name of the server in global configurations hostname to Freenas2.

To my suprise truenas scale does not automatically change the netbios name automatically

I do not know if this is a possible issue or not you folks decide

I hope the correction i made will also resolve my replications and rsync tasks

Again Thank you all for your patience, understanding, help and teaching