Maximum number of concurrent calls (20) has exceeded

Dear community,

I have been having issues with login into my TrueNAS Scale.

HW: iXSystems TrueNAS Mini XL+ (bought a month ago)
SW: TrueNAS-SCALE-24.04.1.1 (presumably latest)

Most of the time when I try to log in, I get “Maximum number of concurrent calls (20) has exceeded” error popup right on the last step of the log in flow (after 2FA, before loading in the home page). Sometimes I get through, other time it hangs on this error and I need to refresh and try again.

I am accessing the UI through HTTPS, over my custom domain with ACME provided SSL certificate. My system is underutilized (just my backup system, no apps are running on it). From SMB perspective, I only have 2 clients connected to it (no transfers, no activity). My token expires after 5 minutes (tried setting it to 30 min, no difference) so it shouldn’t be due to too many open session to the UI. No other services are running (just SMB, not even SSH).

I tried searching in the codebase and found this error in TrueNAS Middleware, unsure if it is relevant or not.

Anyone has experienced the same issue, or knows how to troubleshoot, or what logs to look at?

I would much appreciate this, as it is getting annoying not being able to log into most of the times.

Thank you

PS: I should add, this error persists also after a device reboot.

I’ve just started getting exactly the same problem today. Never seen it before

We’ve seen some instances of this type of error internally on large disk systems in the past but the defects were addressed. I’d recommend grabbing a debug and ideally the HAR and console logs to attach to the private upload so we can try and figure out what is triggering this on your system.

Happy to help out however I can with providing logs if you can give me more information on how to gather and upload them, or point me to a resource explaining how

You can either use the feedback button on the top of the WebUI to raise a bug with the debug, or use the link at the top of the forums.

For the console log depends on the browser, for chrome hit F12 and the inspector will appear, you can save the console log from there.

When you raise a bug a private upload link is provided after it is created to allow you to provide the files.

1 Like

Done (I think):
https://ixsystems.atlassian.net/browse/NAS-129869

1 Like

Done as well (attached a debug log and a screenshot) in [NAS-129898] - iXsystems TrueNAS Jira, feel free to mark it as a duplicate, but hopefully having a second debug log will help.

I suspect this has to do with 1Password extension. Since I was having this issue on Chrome (where I had 1Password installed), I started using Safari instead (without any browser extensions). Today I installed 1Password on Safari as well, and I immediately got this “Maximum number of concurrent calls (20) has exceeded” error.