Network bridge not working with Dragonfish

Hello, I tried upgrading from the latest Cobia to Dragonfish. After rebooting, the Web UI is not available and I can’t ping the NAS. Checking on the NAS itself, it shows that the network connection is not properly working.

I’m using a network bridge to connect both my TrueNAS system as well as a VM installed on it.

  • Resetting Dragonfish to default works

  • Resetting to Dragonfish and uploading my config file leads to the same network issues

Do I need to change something with the network bridge? Were there any breaking changes?

If you need any specs or further information on my network, let me know.

I had the opposite problems, where bridge would be wonky in Cobia, but working fine in Dragonfish. I think after the update though I did have to delete the bridge & set the IPs back to my preferred interface. Afterwards I then just made a new bridge & moved the IPs to the bridge.

I have no reasonable understanding or explanation on why that worked.

I also remember having an issue once where my bridge randomly changed its MAC address (might have been after an update) and my router refused to communicate with the NAS since the IP was statically assigned to a MAC that was no longer valid; quick fix of changing MAC assigned to said IP on the router.

Hopefully this is helpful, otherwise better minds than mine will be needed.

1 Like

I now did the following:

  • Remove bridge
  • Update to dragonfish
  • No network. However, three nics are listed. My main nic, normally enx, is listed as eth0. Manually removing enx and configuring eth0 with Auto dhcp and no mtu establishes the network connection and WebUI is working again.

Using the WebUI, I reconfigure the bridge as it was before the update

Is this a supermicro board by chance?
See: TrueNAS Scale - Virtual IP Address - #8 by essinghigh
Something may have changed with Dragonfish, I don’t have anything on hand to test unfortunately, but generally enx* interfaces will be used for external devices, i.e. a USB Ethernet controller (Ethernet External)
See: — Arch manual pages

I’m using an external ethernet port, as the built-in Realtek chipset has issues with SCALE. It used to work well with CORE.

The board is a A-520M itx board from ASRock