NFS dies and stops responding

We’ve eventually diagnosed the issue with our long standing issue with our NAS, NFS dies and stops, and does not respond to NFS

This is not a networking issue, after a little searching this seems to be an issue which has been posted many times.

Other than restarting the server, we’ve tried stopping the NFS service, which takes many hours to stop, starting again does not resolve the issue.

There is nothing in any logs as to the reason, a console message stating svcname not found is displayed.

Any ideas ?

CORE or SCALE? Have you tried the respective other one?

I’m running FreeNAS/TrueNAS since version 8 and never saw a single event of isolated NFS failure.

Thanks for your reply, this is Core.

I googled and read many NFS died issues on previous versions.

I’m not sure if it’s related to

but it doesn’t play well if NFS just dies!

I may just update to Scale, and try it and test it and see what happens. It cannot get any worse!

1 Like

Before you do that - did you try sticking with NFSv3? That’s all I ever used for VMs. maproot=root, mount from ESXi, done. I always considered the administrative complexity of v4 and up way too high.

We don’t use any of the Kerb/Auth for NFS 4.1, we could change to 3.0, and check if that works better!