No route from guest OS to TrueNas

Networking n00b here…

I’m trying to run Talos OS as a virtualized guest OS on TrueNAS SCALE. I’ve followed the instructions to create a bridge interface, bind my physical NIC to br0, and alias 2 IP to the bridge (one for TrueNAS, one for Talos OS).

Talos OS is reachable on the 2nd IP from other parts of my network, and from within Talos OS, I can ping all other IP’s in the subnet EXCEPT for the TrueNAS IP. I saw this when trying to mount an NFS share into the guest OS from the host OS, and mount reports “no route to host”.

What could I be doing wrong here?

This doesn’t sound right to me–doing this would assign that IP to your NAS, not to the VM.

Ah, my DHCP is configured to hand out the Talos OS IP address via MAC address mapping to the virtualized mac address, so I suppose I don’t need the alias…

However, i’m not sure why that would cause no route from the guest OS to the host OS? Because the host OS would refuse the connection?

Really, I’m not completely sure either; it just seemed like an obvious problem.

No route means exactly as it says.

Your physical NIC is assigned to your bridge interface, good. The aliases on that bridge interface should only be for TrueNAS.

i.e. br0 alias 192.168.0.2/24 – TrueNAS will respond to 192.168.0.2

you should add br0 as a network interface in the VM config, and then the guest can pick up an IP either via DHCP or via static assignment.

Network Tab:


VM Config:

Inside the guest:
image

This may help

TrueNAS Scale: Setting up a Static IP and Network Bridge // Access NAS host from VM

@essinghigh JANK-O-TRON-3000… love the name of the stack :slight_smile:

Yep, looks like the second alias tripped things up. All working now! Thanks so much folks!

2 Likes

Could you also combine a bridge with a bond consisting of multiple NICs?

From what I remember, yes.
I believe I used to do this with the two ports on my X540-T2 and created a bridge interface ‘br0’ with ‘bond0’ as it’s member.

You can. But a bad help text makes it difficult to figure out things.

I had an existing bond with a static IP as an alias and VMs attached to this bond.

Now when you’re trying to remove the alias for assigning it to the bridge you’re going to plug into the bond you get a message: ‘XXX.XXX.XXX.XXX’ is being consumed by Applications, please use a different node IP in applications configuration.

The help text does not mention that you also have to check your VMs.

The solution for this is:

  • Halt VMs having a NIC attached to the existing bond
  • Remove the NICs of the affected VMs
  • Remove the alias from the bond
  • Add a bridge and add the alias to bridge
  • Add new NICs to the VMs that are attached to the bridge

And it works.

(I would have filed an improvement for the help text. But Jira keeps telling me that I don’t have the rights to close tickets.)

I think that is a sort of catch-all permissions error in our Jira instance for whatever reason. You should be able to submit the ticket if you set the issue type to Suggestion.

Making a suggestion has worked.

1 Like