Nvidia GPU not working for plex transcodes

Name:Plex
APP Version: 1.40.3.8555
Chart Version: 2.0.8

I was using TrueCharts for years but now that kubernets are about to meet their demise I’m moving my stuff over to the official charts…

I’m trying to use Plex with the TrueNAS Official chart. When I install the chart, I set 1 Nvidia GPU - everything installs fine.

Now inside my plex server, Under the transcode settings > Hardware transcoding device I assign the NVIDIA GPU (GA106 RTX A2000]… I test transcoding for multiple 1080P files - But it simply does not work now.

I was using this same GPU for years with my TrueCharts install but for some reason TrueNAS’s Chart of plex will NOT let me use it for transcoding. I get the error

An unknown error occurred (4294967279)

I know this is not enough info to troubleshoot, but I’m just getting my first post up.

I have the logs from the workload section in TrueNAS but that’s it, I will take any instruction on what other logs to provide and where they’re located.

Thanks for your time.

2024-07-04 02:54:00.728657-04:00[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
2024-07-04 02:54:00.820579-04:00[s6-init] ensuring user provided files have correct perms…exited 0.
2024-07-04 02:54:00.821917-04:00[fix-attrs.d] applying ownership & permissions fixes…
2024-07-04 02:54:00.822777-04:00[fix-attrs.d] done.
2024-07-04 02:54:00.823778-04:00[cont-init.d] executing container initialization scripts…
2024-07-04 02:54:00.825668-04:00[cont-init.d] 40-plex-first-run: executing…
2024-07-04 02:54:00.973400-04:00Plex Media Server first run setup complete
2024-07-04 02:54:00.974310-04:00[cont-init.d] 40-plex-first-run: exited 0.
2024-07-04 02:54:00.976344-04:00[cont-init.d] 45-plex-hw-transcode-and-connected-tuner: executing…
2024-07-04 02:54:01.043922-04:00[cont-init.d] 45-plex-hw-transcode-and-connected-tuner: exited 0.
2024-07-04 02:54:01.045596-04:00[cont-init.d] 50-plex-update: executing…
2024-07-04 02:54:01.073146-04:00[cont-init.d] 50-plex-update: exited 0.
2024-07-04 02:54:01.074381-04:00[cont-init.d] done.
2024-07-04 02:54:01.075421-04:00[services.d] starting services
2024-07-04 02:54:01.083227-04:00Starting Plex Media Server.
2024-07-04 02:54:01.084257-04:00[services.d] done.
2024-07-04 02:54:14.103729-04:00Critical: libusb_init failed