Nvidia RTX A1000 Single Slot Ampere based GPU for Transcoding

If you’re not budget oriented, and are looking for a single-slot PCI-powered SFF GPU for transcoding, then this might be a good option for you.

I purchased it directly from Nvidia. I received mine today, plugged it in, and here are the results:
My software/hardware - Dragonfish-24.04.1.1 on an ASRock Rack X570D4U-2L2T

root@truenas:/home/admin# lspci -v | grep NVIDIA
2e:00.0 VGA compatible controller: NVIDIA Corporation Device 25b0 (rev a1) (prog-if 00 [VGA controller])
        Subsystem: NVIDIA Corporation Device 1878
2e:00.1 Audio device: NVIDIA Corporation Device 2291 (rev a1)
        Subsystem: NVIDIA Corporation Device 1878
root@truenas:/home/admin# nvidia-smi
Tue Jun 11 14:21:09 2024       
+---------------------------------------------------------------------------------------+
| NVIDIA-SMI 545.23.08              Driver Version: 545.23.08    CUDA Version: 12.3     |
|-----------------------------------------+----------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |         Memory-Usage | GPU-Util  Compute M. |
|                                         |                      |               MIG M. |
|=========================================+======================+======================|
|   0  NVIDIA Graphics Device         Off | 00000000:2E:00.0 Off |                  N/A |
| 30%   47C    P0              N/A /  50W |      1MiB /  8188MiB |      0%      Default |
|                                         |                      |                  N/A |
+-----------------------------------------+----------------------+----------------------+
                                                                                         
+---------------------------------------------------------------------------------------+
| Processes:                                                                            |
|  GPU   GI   CI        PID   Type   Process name                            GPU Memory |
|        ID   ID                                                             Usage      |
|=======================================================================================|
|  No running processes found                                                           |
+---------------------------------------------------------------------------------------+

I haven’t tried it with any applications yet but it looks like it might work. Will keep you posted.

1 Like

Well, this is my first time using TrueNAS and trying Jellyfin. I couldn’t seem to get it to work for transcoding.
image

Shouldn’t something show up under the GPU resources there?

Also, in my nvidia-smi output for Graphics Device, is it normal for it to show P0 instead of model number? I noticed when I ran nvidia-smi -q one of the outputs stated “Performance State :P0” so maybe it correlates to that?

Well, I took a closer look at the Nvidia Linux driver release notes, and it appears the desktop RTX A1000 doesn’t show supported until 550.90.07 and this version of TrueNAS is at 545.23.08. So, I either have to wait or figure out how to install the newer version.

1 Like