Odroid H3 network issues

In had help from honeybadger in 2022 with my install regarding the RTL8125B nic, ref: Readonly forum that solved my issues.

Last week I messed up my network configuration. I tried to solve this by doing a fresh TrueNas reinstall. However the reinstall reports an error on the Realtek firmware install.

So I tried to redo the tunable settings in the TrueNas cli, as suggested in 2022 by honeybadger, but now I get an error on “type=LOADER” that “LOADER” is not a valid type anymore.
Any clues on what I have to do to get this working again?

If you have acces to the network, I would suggest doing so by the WebUI.

Thanks Dave, but I don’t understand where to do so in the webUI?
I am using TrueNAS-SCALE-23.10.2 on my Odroid H3. In the TrueNas webUI I can’t find any options to install the RTL8125B nic firmware?
I looked in system settings / advanced and and boot.

Doesn’t SCALE have a tunables tab? Advanced Settings Screen |

Thanks for your help, I found the “Sysctl” widget where I can set variables.
However I need to set 2 variables:

  • if_re_load value=YES type=LOADER enabled=true
  • if_re_name value=“/boot/modules/if_re.ko” type=LOADER enabled=true

In the widget I can only set the variable and the value, but where to set the type setting?

I tried for the first line, but get error: Sysctl ‘if_re_load’ does not exist in kernel.
Also for the second: Sysctl ‘if_re_name’ does not exist in kernel.

I’m no expert of SCALE, let’s wait for @HoneyBadger or some other experienced user to chime in.

The real answer, of course, is don’t buy systems made of garbage like Realtek NICs.


Sadly it appears they are becoming the norm in the consumer hardware, even on high-end boards.

Hey @h.intveen

SCALE doesn’t have the “LOADER” tunable type - and to wit, it shouldn’t require this tunable set in order to load the Realtek modules.

Can you show us the logs or details around the error on the Realtek firmware? You’ve mentioned webUI access so I assume it’s either working without the firmware blob or you have an alternate NIC installed as well.

I see the error on the Realtek firmware loading on my monitor in the first few lines after booting the system, during boot this scrolls off screen. I tried to find this error in /var/log but I could not find it there except for an old message from February 24th (before the reinstall):
./apt/history.log:Commandline: apt install -V -y firmware-realtek

I have network access with the RTL8125B nic, it is supposed to be high speed.
The error message loading the firmware bothers me.

I have a couple systems with RTL8125B 2.5Gbe NIC on it, the drivers should be already loaded and available on SCALE, no tunables needed. I am using the 24.04-RC1, but not on the ODROID specifically. It has a newer kernel / driver set than 23.10.2, might be worth loading it first to see if the problem solves itself by upgrade.

In the meantime if you can get a screenshot of the firmware error message scrolling by, that would be helpful to troubleshoot further. You can look at the output of dmesg as well.

The scrolling boot log on my monitor doesn’t look like the original log, it is now loading a (TrueNas) ramdisk?
I checked the output of dmesg but can’t find any firmware errors anymore.
Tried grepping the log output, see below, can’t find any anomalies.

  • grep on “firmware” only shows the audio driver
  • grep on “RTL8125B” shows eth0 and eth1
    So it looks like I have wasted your time :cry:
    Sorry about that, thanks for the great support from the TrueNas community!

root@truenas[/mnt/tank/Docs]# grep “firmware” dmesg20240412.log
[ 6.461737] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/icl_dmc_ver1_09.bin (v1.9)
root@truenas[/mnt/tank/Docs]# grep “realtek” dmesg20240412.log
[ 6.782625] snd_hda_codec_realtek hdaudioC0D0: ALCS1200A: SKU not ready 0x00000000
[ 6.783351] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALCS1200A: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:hp
[ 6.783356] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 6.783359] snd_hda_codec_realtek hdaudioC0D0: hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 6.783361] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[ 6.783362] snd_hda_codec_realtek hdaudioC0D0: dig-out=0x1e/0x0
[ 6.783364] snd_hda_codec_realtek hdaudioC0D0: inputs:
[ 6.783366] snd_hda_codec_realtek hdaudioC0D0: Mic=0x18

root@truenas[/mnt/tank/Docs]# grep “RTL8125B” dmesg20240412.log
[ 1.638095] r8169 0000:01:00.0 eth0: RTL8125B, 00:1e:06:45:01:4e, XID 641, IRQ 127
[ 1.658318] r8169 0000:02:00.0 eth1: RTL8125B, 00:1e:06:45:01:4f, XID 641, IRQ 128

No worries and glad you got it figured out!

1 Like