Permissions issue from ix-apps folder

Plex will not update cover art due to a permissions error

Migration from core to TrueNAS-SCALE-23.10.2

Permissions in the ix-applications folder is root/root

Apps are all run 568/568

If I change plex to run 1000/1000, it cannot see my media because my media folder is 568/568 (IDK why, I think I was troubleshooting issues when truenas was mad that smb was the same folder as media and this was the only thing that worked at the time.)

Should I change my media folder permissions to something else and have plex run that as well? I’m afraid changing this may break smb somehow.


4x Intel Xeon e7-4850v2 12 core
Supermicro X10QBi
Xeon 48 Core 128GB DDR3 ECC REG
4x PCI-E 3.0 x16

Without further information it’s hard to tell. Isn’t the cover art stored in a folder created by the Plex app itself? If it’s also stored in the media folder (that’s created by you somewhere else) you could just change the permissions of that. Since you mentioned SMB and you shouldn’t / can’t share ix-applications I think it’s located elsewhere.

I think the problem lies in that you can only change owner and group, you can also add other users with appropriate permissions.

Yeah, but I believe this is the ix-applications folder. And the reason it was working before was because plex was running as 1000/1000. Now it is 568/568. Also no way to change ix-applications folder, and plex will not start as 1000/1000.

Can’t you grant user 1000:1000 also rights to the media folder or did I missunderstand you?

Post the folders and their permissions to let us have a look.

current permissions for ix-applications

when I tried to change them to apps/apps to match plex running at 568/568

media folder… I know it looks like a mess but at one point I was desperate to get it to work and this worked at the time.

As of right now, when I run plex as 1000/1000 I can upload artwork and change posters, but cannot access media (it is 568/568). When I switch back to running plex as 568/568, I can play media but cannot fix artwork.

So youre suggesting to change all my media to 1000/1000 and run plex as 1000/1000.

This may be the answer, I’m just worried it will mess up my smb share somehow. You think I should try this next? Apply 1000/1000 recursively and all child datasets?

Simply adding a user will on the file ACL will not break SMB.

UID 1000 should be a local user with no elevated privileges, so I don’t see any harm in granting that user rights to your media folder.

Yes, add 1000, apply recursively if media is just a folder you created somewhere on your pool.

Hi, I’m super new at this. This is happening to my install in 24.10. Does anyone know if this fix carries over? Plex and media access (SMB) lock each other out. I’m getting a bit frustrated because I can’t seem to get HTTPS/SSL to work either.

Is that a typo? If accurate you are running SCALE 24.10 nightly builds, i.e. prerelease builds, they can break at any time for any reason.

24.04.0 is the current stable version, with 24.04.1 planned to be released on May 28th.

Either way, you should not store things in ix-applications. Let TrueNAS use it for containers only and store your configuration files, media, or things like thumbnails in a place linked to through using host paths.

Yes, sorry, I’m on 24.04 main, not nightly. So none of the apps or anything should go in the default dataset? I guess I’m just having a hard time knowing where to get started, because either the instructions don’t match the UI, or things just aren’t tackled in a linear manner. But I’ve been having trouble with TrueNAS since the beginning.