PiHole will NOT install after Cobra upgrade from Bluefin

SOLVED (With workaround)
I have found a solution to my March 21 post below. The last sentence of the error mentions “namespace” and when I finally tried the install with a name other than “pihole” (which is the default name) it install as it should.
If anyone knows how to remove the LOCK on the name “pihole”
in my system i’m all ears…

From: Mar 21, 2024
Pi-Hole question: I had been using Pi-Hole on Truenas Scale for about a year until upgrading from Bluefin to Cobia (Version:23.10.2) in February. I struggled some with Nextcloud and Syncthing after the upgrade but got both of them running without reinstalling them. Pi-Hole (TrueCharts version) on the other hand did not survive. Other apps will install OK, but since the upgrade TrueCharts and TrueNas versions of Pi-Hole will not install they both fail with the following cryptic error message.
[EFAULT] Failed to install App: Error: INSTALLATION FAILED: create: failed to create: secrets “sh.helm.release.v1.pihole.v1” is forbidden: unable to create new content in namespace ix-pihole because it is being terminated