Plex on SCALE-23.10.2

I recently set up a new server and went to scale instead of core. I was easily able to set up on core. I am having a hard time to getting PLEX to run as a server. I can easily install it and run it but it wont let me set it up as a server.

What do you mean “as a server”? What are the difficulties you are experiencing? Are you using the App?

Yes I’m using the app on the official channel. when I go to the web address Plex loads but there is nowhere to add my media folders and share. It shows its looking for my previous Truenas plex server.

If i remember correctly in plex under devices you can delete the old server.

I was able to get it working by installing the version and not the 2.x. Ill hold off until there seem to be more people with notes on this version.

I’m still have problems with the version you got working. When I open a shell and do a df -h I can see the SMB share there mounted but for some reason I cannot fathom why I can’t add my media. I think I was prompted to install the server version when I tried to add media. I’ve been back and forth on this for days. I’ve looked here on this forum, Reddit, YouTube been Googling and I’ve not found the solution to my problem. I’ve reinstalled 4 times as I’ve wondered if I’ve messed up with the sharing. I installed Jellyfin to see if that worked and it did, first time but it’s Plex I want to get working.

The plexapp on truenas seems to cause lots of trouble for alot of users.

So I went the route of running it in a VM.
Since dragonfish you could also run it in a sandbox.

I suggest a ubuntu or mint VM. But you need GPU passthrough for transcoding more than one stream and create a mountpoint for the SMB share.

But its the best solution IMO for plex.