Power button not working

I’ve just installed TrueNAS Scale 23.10.2 and I’m having issues with powering on the system. I already set AC recovery on my system before the build and it’s the only thing that saved me. If I shutdown the machine by command or UI, the power button does not work to power on the system, can’t even get it running to go in the BIOS. Is anyone else having this issue, and is there a solution for this?

Check the connection to the button? Check the button itself?

There’s no context to this post. It’s not clear if this is a brand new system, or if it’s an existing system whose power button has worked fine before.

We don’t even know the hardware.


…this is obviously not a TrueNAS issue.

We used 2 Dell OptiPlex 7060 for testing, both of them ran into the same issue. The system are used, formally running Windows 11, and did not have any issues except they violated the 5 year company policy.

The systems have;
32GB of RAM (DDR4)
2* 3TB HDD
1* 250GB SSD (TrueNAS OS)
Intel Core i7 VPro (gen 8)

The power button worked fine before installing, and they didn’t have any issues prior.