Presence of keyboard halts boot-up process?

I had reason to replace the SSD of my boot pool. Afterwards I had to reinstall TrueNAS. That worked. When it came time to reboot, the screen showed all sorts of messages and ended with this:

b1k4 :HardDisk - Alias (null)
      PciRoot (0x1)/Pci(0x3,0x0) /Pci(0x0,0x0)/VenHw(CF91FAC5-C24E-11D2-85F9-00A
      OCSSEC93B, 82)/HD(1,GPT,C220A99D-604D-4DC6-B250-69991060A4DC,0x800,0x400001)
b1k5 :HardDisk - Alias (nuil)
      PciRoot (0x1)/Pci(0x3,0x0)/Pci(0x0,0x0)/VenHw(CF31FAC5-C24E-11D2-85F3-00A
      OC93EC93B, B2)/HD (2, GPT, 4D1EC5F1-8F3A-4F97-A5F7-7F36FB3AAD17,0x401000,0xE8A07801)

blk6 :HardDisk - Alias (null)
      PciRoot (0x1) /PC1(0x3,0x0)/Pci(0x0,0x0)/VenHw(CF31FAC5-C24E-11D2-85F3-00A
      OC93EC93B, B3)/HD(1, GPT, 763EC928-2C91-4EF3-9674-8C5E61112D49,0x1000,0x74705801)
blk7 :BlockDevice - Alias (null)
      PciRoot (0x1)/Pc1(0x3,0x0)/Pc1 (0x0,0x0)/VenHw(CF31FAC5-C24E-11D2-85F3-00A
blk8 :BlockDevice - Alias (null)
      PciRoot (0x1)/Pci(0x3,0x0)/Pc1(0x0,0x0) /VenHw(CF31FAC5-C24E-11D2-85F3-00A
blk9 :BlockDevice - Alias (null)
      PciRoot (0x1)/Pci(0x3,0x0)/Pc1 (0x0,0x0)/VenHw(CF31FAC5-C24E-11D2-85F3-00A
OC93EC93B, 82)
bIkA :BlockDevice - Alias (null)
      PciRoot (0x1)/Pci(0x3,0x0)/Pci(0x0,0x0)/VenHw(CF31FAC5-C24E-11D2-85F3-00A
ОС9ЗЕС9ЗВ, 83)

Press ESC in 1 seconds to skip startup.nsh, any other key to continue.

Regardless of what input I chose, ESC, space, any other key or nothing, I ended up with that shell prompt and further processing halted. Removing the keyboard from the USB port allowed the bootup process to go forward.

Why would having the keyboard connected disrupt booting into TrueNAS?

Please provide what version of TrueNAS you installed and your hardware. Did you restore a configuration file?

Have you tried to reinstall TrueNAS? If you previously restored a configuration file, try it this time without doing so. Make sure the system operates normally.

It is Dragonfish-24.04.0. I installed on a Supermicro SuperServer 6018U-TRT4+.

It was a re-installation, because I had to swap out the boot pool SSD for a new one. It was before I restored the configuration I had saved prior to the re-install.

If this is for a business, I would not recommend Dragonfish yet, it is only recently released. I would use an earlier version. Just saying.

It is going to be mainly my Time Machine backup destination, serving video ripped from DVDs and a repository of files archived from my family’s individual computers.

I went to → Get TrueNAS → Download TrueNAS Scale. I installed what I found. I did not know any better.

I would venture to say that 24.04.0 is good for people who want to be on the cutting edge, and do not mind fooling around with it. Once it has had a maintenance update the it should be better suited towards folks who would rather not debug a system. Of course you could just use CORE which is very mature. It should be supported for awhile.

Good luck whichever way you go.

Is there an expected release schedule? Do we know, when that first maintenance release will come out?

Hi Dominik.

A maintenance release of Dragonfish is likely within the next several weeks, and is currently undergoing testing.

That being said, a maintenance release is unlikely to resolve the issue you have noted, above. It does not appear to be an issue with TrueNAS, as you appear to be dropped into the EFI shell. (can you check the BIOS boot list? failing to find your boot disk in the list, it may be dropping you into the EFI shell, if that is a fallback)

Incidentally, we have about 25,000 users running Dragonfish 24.04.0 today, just three weeks after its release.


Is the boot SSD attached through a USB adapter, by any chance?

GRUB very typically loses its marbles any time new devices are attached—which is somewhat annoying for a storage platform…

That is annoying, you are sure there isn’t some key stuck on the keyboard as well? We all boot with keyboards from time to time, first I’ve heard of this kind of issue in well, ever.

Try a different keyboard to rule out a stuck key.

No. It is attached to a SATA Data port on the motherboard.

1 Like

I have since used that keyboard on a PC. There is no indication that the keyboard has a stuck key. It also did wait for 5 s to drop into the shell, if I didn’t do anything.

You were running this version of TrueNAS before you replaced the boot drive.

  1. Did you enter the BIOS and make sure the boot drive is selected correctly? Replacing a drive on the same port does not mean it will still be the first boot device.
  2. Did you try to reinstall TrueNAS again? Maybe it became corrupt?

– Supporting that idea is the fact that the messages are screwy!

Look at the letters and numbers, “b1k” “blk” “bIkA” “nuil”, a bit messed up.

Oh, that’s because I failed to correct the OCR done of the photo I shot of the screen. Being mainly a Mac user, I am usually a BIOS guy.

However, I had the TrueNAS ISO on a USB flash drive, and the BIOS gave preference to bootable devices on the USB bus. During the TrueNAS install I selected the 16 GB SuperMicro SSD as the install destination. When the installation was complete, I shut down the server and removed the USB flash drive. At that point the keyboard was still connected, having been necessary before in making the few configuration choices of the TrueNAS install.

In case anyone is interested, here are some of the shots of the screen I took (I apologize, for their unedited, ugly appearance):

Just for kicks, I am going to shut the server down now, reattach the keyboard, and will see what happens.

1 Like

That is all fine and good, however when you boot the computer after you removed the USB flash drive, you still need to tell the BIOS that the SSD you just installed into the machine that it is now the first drive and to boot from it. You did not say that you performed that step. Or press F11 to select the SSD to boot. But the BIOS it what does need to be done eventually. As someone else stated, the UEFI BIOS shell is what you get because you are not booting from the SSD. Why the keyboard is acting funny, I can’t say.

If I am incorrect, please let me know, however I hope I am correct just to solve this problem for you.

1 Like

Out of curiosity, did you post anywhere what model keyboard this is? Its not one of those with a USB hub built-into it or something is it?

It is a very generic Dell keyboard. I wish it had a USB hub in it, so that I could plug the mouse into that. I have always thought that Apple’s approach with the short-cabled mouse was much superior, because of the more straightened-out cabling.

I did not do anything to the BIOS to make it boot from the SSD. With the keyboard removed it just did.

Also, yesterday’s test of a reboot with the keyboard plugged in turned out negative. The system booted straight into TrueNAS.

At this point I am chalking this up to being an unexplained quirk.

Should I have to reinstall again at some point in the future, I will make sure to check the BIOS boot preference settings, before restarting post install.


Solar Flares !