Printer cannot scan to SMB share


I’m very new in TrueNas.

I’ve setup an old machine with Truenas Core 13.
I have 2 drives shared with SMB.

I use the 2 disks as network shared data im my office.

On my windows PC i can acess the data, write, etc… without no problems at all.

I have a Lexmark XS595 printer and prior to send Scans to any folder i have to validate the choose path.

In the printer driver i have to place the path to where i want to save the scans and the driver does a validation of the path but it neves return a good result.
I’ve tryed log as Guest an with the 2 diferent users of the shares.

Sorry if the explanation isnt very good but as i sayd before i’m very new with this OS. Please wask me any detail.

I’m using this OS because is lightweight and it’s free


How old is this printer and does it support more recent versions of SMB? The reason I ask is that SMB 1 has been deprecated for years due to security concerns. It is turned off by default in TrueNAS.

That would help explain why you can log in with windows machines but not with the printer, even if you use the same credentials. Security for your TrueNAS can be reduced to SMB 1 levels but keep in mind that it will make every SMB connection to the NAS (including other shares) less secure to do so.

You can google for the commands in TrueNAS to re-enable SMBv1 you may also have an authentication problem on your hands. See here

1 Like

To enable SMB 1 on TrueNAS, open the GUI, select “Services” > SMB > Edit> Advanced Options & enable SMB1, save, then stop then start SMB service (last 2 may not be needed but good habit I think). A lot of older SMB sharing devices just never updated to newer specs. Good luck.

1 Like

For what i can see the printer was builted in 2019.

And how can i reduce to SMB 1, at least to test.

And if it results how can i blok all external IP’s from acessing



Tks it worked.

1 Like

I use a Raspberry Pi for all SMB1 related NAS storage. I only need it for my kids and my Sonos music system. Neither is ever likely to get access to my NAS for security reasons.

Good luck with the blocking, etc.

Tks again