Problem installing SCALE on QNAP--display goes crazy when installer starts

I’m just trying to get started with TrueNAS. I’m pretty experienced with this sort of thing. I acquired an extra QNAP TS-453 Pro so I figured this should be easy, but nooooo :smile:

  • Upgraded QTS and tested the system and drives–all good.

  • Pulled out the drives and removed the QTS DOM (disk on module).

  • Installed a brand new, unformatted 32GB DOM.

  • Downloaded the SCALE ISO and used RUFUS to build the USB install media.

  • Plugged the install media into the TS-453, booted into BIOS, saw that #1 was the DOM and #2 was the install media, no other drives detected.

  • Booted and the BIOS quickly found and ran the install media.

  • I successfully saw this screen:

  • Chose the first option and…disaster :grimacing:

So it appears that the installer is running fine, but with the garbled video display it’s kind of hard to use!

The “c” and “e” keys work fine. I could edit the install commands, but I have no idea how to edit them to fix this problem.

I tried going into BIOS and redirecting the console ports and using the second option but no joy with that, either.

I searched the old forum and the new forum and found nothing helpful. There was one similar thread in the old forum but it did not seem to offer a solution.

1 Like

You can installing on a different machine and moving the boot device over afterwards.

It should also be possible to override the video mode, by telling GRUB to pass certain options to the kernel when loading it. Unfortunately, I’m not familiar with the specifics.

I have no other machine that will accept a DOM for installation.

The GRUB options method sounds like the correct one. And it seems those need to be on the installation command line. It would be pretty wonderful if someone had some guidance on that.


Nobody? One would think there’d be a lot of QNAP hardware being set up with TrueNAS?

I noticed that the SCALE iso is booting up into GRUB 2.06. Is there an easy way to upgrade to a more recent version of GRUB on the install media?

I don’t think GRUB is the problem here (nice change of pace).

Most of their hardware is not that good anyway, so it’s not suoer popular outside of the “I’m sick of this, I hate it, how do I recoup some of my losses by replacing the OS?” sort of niche.

In any case, this is not a TrueNAS thing as much as it is a Debian or even Linux thing. Widen your search accordingly and you’ll probably find someone who’s figured out the details.

1 Like

My recollection from other folk posting here about QNAP conversions to TrueNAS that a user over in the QNAP forums posted a script to deal with the display during the boot process. I’d suggest searching for it.

I dislike QNAP due to the outlandish claims made by the marketing department. The hardware is nicely built for the price point.

i posted the LCD fix for QNAP Truenas by Elvis here

It was for a TS-653A, so not sure if it would work for other models or whether you need to make some changes to the script. I can’t help with that since i’m not the original coder for the fix.

I merely explained how it worked and how to apply in truenas via init script.

but from what i can see the TS posted, his issue is more to do with some gibberish appearing on his monitor, rather than the small lcd screen on the qnap (he may need help with that also, but i assume his main issue is the former which is a separate matter).

I never encountered that issue, so i’m not sure how to help with that.

I see he installed truenas onto a dom, i didn’t do that. I saw one user replace the dom and install truenas into it, so i know way of doing it works.

For myself i tried 2 other methods

  1. install truenas onto a usb m.2 nvme ssd external enclosure, connected to the QNAP via usb.

  2. install directly onto a hard drive installed in the QNAP (this model had no ssds in it, so couldn’t select that, so opted for regular hard drive)

Some positive progress to report:

  1. I was writing my install media using rufus in .iso format.
  2. The QNAP BIOS would not boot that using UEFI. I surmised that this might be a problem.
  3. I redid the install media using rufus in dd format, and enabled the “fixes for old BIOS” option.

Now the QNAP BIOS will boot the install media using UEFI and the garbled display problem is fixed :slightly_smiling_face:

Installation is proceeding but it is veeeerrrrryyyy slooooow.

I’m going to ignore it until morning (about 8 hours from now) and, with luck, it will successfully complete overnight.

There’s no M.2 slot in this old QNAP machine. If using the DOM winds up being a performance problem then perhaps I’ll get an inexpensive NVMe SSD and pop that in a USB M.2 carrier that I already have.


just wondering, but couldn’t you have used m.2 nvme in an external usb enclosure? this is what i did and it worked. This way, even if your nas does not support m.2 ssd, you can get it via this method.

I did not notice any issues with this sort of setup. Downside is you can’t then do a raidz to pair 2 drives for your truenas install location i guess.