Problem with apps permissions


I have problem accessing data in mounted dataset Host Path regardless of app.

I have created a dataset mainDataset under my pool with default settings. I created a user and group and set as owner. I added a SMB share to this dataset and transferred some files there from Windows. Then I tried installing e.g. Emby, Jellyfin, Immich, and mounting e.g. Host Path /mnt/dataPool/mainDataset/media/film to /media but in no app the data could be accessed.
The apps dataset ix-applications is on the same pool as mainDataset.

Funny thing is, I first did a dummy install of Truenas Scale on a laptop to test and everything worked with default settings. Now I tried replicating it on my “real” nas and run into this issue. I can’t find any setting that differs (the version differs and this happens on vs 24.04.0).

The only solution that worked was setting user/group of app to 3000 instead of 568.
I did try to add apps as a member of the owner group of the dataset, as well as to add apps user/group with read/execute to the dataset permissions.

And just because I posted here, I found a clue to what’s going on.

I the setup that doesn’t work, permissions are set across the dataset as drwxrwx— as opposed to drwxrwxr-x.

I guess I can fix this with a chmod command, but how did I end up here?

Not sure how you ended up there but I can tell you that you will not be able to chmod the files if you’re using the default Restricted ACL mode for the shared dataset, you’ll get permission denied errors.

Someone else will hopefully correct me if I’m wrong, but I suspect you will need to apply the ACL permissions recursively for it to fix the issues you’re seeing.

1 Like

Thanks! Yes, that solved it. For some reason, there’s two “other” users, and the one marked default had no permissions.