Proxmox keeps booting into the installer

I’m trying to add TrueNAS Scale to my proxmox server and I cant get the install to boot. The installation goes fine, says its good to go and to reboot, I do so, and it just boots back into the installer.
I’m using the legacy BIOS option in proxmox as the installer wont boos on a UEFI VM.

(I’m fairly new to anything fancy like this, currently just have 2 VM’s running game servers ATM, so I may need slightly more detailed instructions compared to the average Joe)

I find sometimes that I need to remove (unmount) the installer cdrom/disk in order for my VM to boot from the actual install disk.

Could you perhaps try to remove the cdrom device in Proxmox settings for the SCALE VM?

Just tried that, seems to be trying to boot from CD? Almost like the install failed to write to disk?

Try to recreate the VM, install, shutdown, remove the CDROM device, then boot.

Been playing around and some how (even on new VM’s) the boot order keeps being made CD/DVD first. Removed them from the list so it was just the virtual drive and that’s worked a treat. thanks for your input!

Good show. Happy to help.