RAID-Zx with just 1 data disk

During another discussion about RAID-Zx expansion, it was mentioned that it was possible to create a RAID-Zx vDev with just 1 data disk;

RAID-Z1 - 2 disks minimum
RAID-Z2 - 3 disks minimum
RAID-Z3 - 4 disks minimum

Looks like Solaris 11.4 has that already. Makes me wonder if that was possible all along and was just assumed it would be silly. (Silly without RAID-Zx expansion!)

https://docs.oracle.com/en/operating-systems/solaris/oracle-solaris/11.4/manage-zfs/raid-z-storage-pool-configuration.html

You need at least two disks for a single-parity RAID-Z configuration and at least three disks for a double-parity RAID-Z configuration, and so on.


So, was it a conspiracy to hide that fact?
Or just implied silliness?

Okay, now it appears that the single data disk “feature” for RAID-Zx is NOT tied to RAID-Zx expansion.

My current desktop does not have the RAID-Zx expansion feature, which is in OpenZFS master, (>2.2.5). I’m using 2.2.3 and I was allowed to create a 2 disk RAID-Z1 pool. Plus, was able to offline one of the drives and yet still have full access to the pool;

root@me:~# zpool status newpool
  pool: newpool
 state: DEGRADED
status: One or more devices has been taken offline by the administrator.
	Sufficient replicas exist for the pool to continue functioning in a
	degraded state.
action: Online the device using 'zpool online' or replace the device with
	'zpool replace'.
  scan: scrub repaired 0B in 00:00:08 with 0 errors on Fri Aug 23 17:52:44 2024
config:

	NAME                             STATE     READ WRITE CKSUM
	newpool                          DEGRADED     0     0     0
	  raidz1-0                       DEGRADED     0     0     0
	    /disk1.sparse                ONLINE       0     0     0
	    /disk2.sparse                OFFLINE      0     0     0

errors: No known data errors

Next, I re-added the sparse file I had OFFLINE and removed earlier. It re-silvered just fine;
root@me:~# zpool status newpool
  pool: newpool
 state: ONLINE
  scan: resilvered 2.33G in 00:00:10 with 0 errors on Fri Aug 23 17:57:02 2024
config:

	NAME                             STATE     READ WRITE CKSUM
	newpool                          ONLINE       0     0     0
	  raidz1-0                       ONLINE       0     0     0
	    /disk1.sparse                ONLINE       0     0     0
	    /disk2.sparse                ONLINE       0     0     0

errors: No known data errors

So, I guess single data disk RAID-Zx were always an option.

Thanks for the test… yes it was feasible, but not recommended. It was blocked in the web UI.

Mirrors were faster and more reliable.

It’s only with RAID-Z expansion is there a reason for 2 drive Z1