Replacing Disk must be larger than X bytes

TLDR; (short version:)

I wanted to reply to this thread, but it looks like the forum software has changed and the thread was locked. So, I thought I would post my solution here in hopes that if someone has the same problem, they can use my very simple solution: reboot the server.

Long story:

In SCALE I was replacing two drives of a new 5 drive pool that were offlined 2 weeks ago and sent back for replacement. (The two bad drives came with or quickly developed bad sectors if it matters as indicated in SMART but had no actual usage errors). Pool ran degraded for two weeks, which i was fine with me as it was brand new and backed up. Upon getting the replacement drives I attempted to start the re-silver process.

The first drive was replaced successfully using the replace command in the TrueNAS Scale GUI, but with the second drive, I got an error " Replacing Disk “must be larger than X bytes”

First I tried the command line, “zpool replace …” which was mentioned in that thread. It worked but it did not set the drive metadata properly, specifically the GPTID was not used as a drive identifier. So, I don’t recommend that solution for fear that it may cause problems in the future.

So, I offlined that drive again, tried doing a Truenas wipe, and also tried using the drive’s SED/secure erase feature, nothing worked. And yes, the drive was the same exact size as the drive it replaced. The error was not correct.

After some searching, and not finding much, I decided on a whim to reboot the SERVER and that seemed to have done the trick.

Just thought I would post my three-finger-solute solution to save someone a few hours of troubleshooting. Hope it works for ya.