Restore destroyed pool

Hi,
a while ago I needed to move data offline from two TrueNAS systems with the help some external harddisks, what I did was:

  1. connect HD1 to NAS1
  2. create a new encrypted pool on HD1 (and save the key somewhere)
  3. copy/move files to HD1
  4. export HD1 pool from NAS1
  5. connect to NAS2
  6. import pool from HD1 with encryption key
  7. copy/move files from HD1
  8. export HD1 pool
  9. repeat step 1 with HD2

When I was satisfied and copied/moved everything I needed I reconnected all those HDs and destroyed the pool for good mesure.
Now, obviously, I need to recover some files on some of those HDs, I tried with

zpool import -D

but

no pools available to import

I even tried with testdisk but no partitions where found.
I have zero experience with recoverying a destroyed pool, should I forget about those files and move on with life or is there something else I can try before giving up?

Thanks

D.

How did you “destroy” the pool? Did you also wipe the drives? (I believe the GUI gives you an option to wipe the disks upon pool destruction.)

1 Like