Safe restart when no response from webui, ssh, and no output from directly connected monitor?

Before even considering what the root cause of my problem is, I just want to restart my machine, but all the safe options I know of aren’t working. Even UPS, in my time of need is not triggering a safe shutdown after 2 minutes of battery power (which I previously configured and tested).

Can successfully ping the server too.

Hard restart is looking like my only option, but I just want to check if I’m missing something.

May be worth noting that my instance of Syncthing is working perfectly (and I can access its webUI). But TrueNAS itself appears completely unresponsive. I seem to have no way in.

I am occasionally having the same issue.

Ping works, some services work, but UI and Plex stop working. Ping working suggests O/S is still alive, so presumably Kubernetes or the Middleware or nginx has crashed. There are no errors in the log which make any sense or which help me diagnose the issue.

I have to do a hard reset to recover.

Thanks for the reply. Which logs are you referring to? And how did you access these logs? (sounds like maybe you had access to your server in a way that perhaps I don’t)


On my systems, the powrbutton triggers a shutdown…

Have you tried the power button?

And if that doesn’t work… then hold the button down for 5seconds until it turns off.

Yes. All of the above is specific to your motherboard and chassis etc, but it’s fairly common behavior

Yes, I forgot to mention that I’d tried just pressing the power button - nothing happens.

I will try a hard reset but they’re of course very undesirable, so I just wanted to first throw a question out here to see if there was something else I could try.

Thank you.

1 Like