Server Hardware "Upgrade" Complete

I had been running Core for years without issue with Plex and UniFi Controller in separate jails … on an X470D4U/5800x/4x16GB 2666 ECC UDIMM’s with a hodge podge array of assorted SAS and SATA drives from 2TB to 8TB … no redundancy

It worked though . .and worked well

I knew the writing was on the wall with moving to Scale at some point and was eager, but dreading the move because I don’t know what the heck I’m doing, lol.

I got a bug up my butt to build a new AM5 setup for a new server. I already have myself, my wife and daughter on AM5 now… so I thought … “Hey … lets get TrueNAS on AM5 too!”

I have been running server type hardware for years with Intel and then switching to the AM4 server board … always running ECC RAM … HBA card flashed to IT mode … but my drive configuration was always bad.

This time I focused on getting some redundancy but let the server hardware part slide

I picked up 2 x 14TB drives for $109 USD a piece and am currently running them in a mirrored configuration

I pooled together 4 of my SATA 4TB drives and run them in Raidz2 now and put all the other SAS and SATA drives up on the shelf… .so hard drive configuration is much better now …

but …

Hardware wise … pretty much running everything not recommended

Ryzen 5 7600 w/AK620
ASRock B650E PG Riptide using it’s Intel 2.5GB “killer” NIC
2x24GB Gskill Flare X5 EXPO 5200 1.1v non-ECC
Rosewill PMG850 850wtt 80+ Gold PSU
Intel ARC380 6GB for hardware transcoding in Plex
CORAL TPU M.2 A+E Module for Ai detection in Frigate in the near future. Removed the WiFi card and used slot for this
IBM M1015 (LSI9211-8i) IT Mode
DARKROCK Classico Storage Master Case
1500va UPS

I thought I’d load up Core to get data moved around on new drive configurations … but Core wouldn’t boot on my shiny new unneeded AM5 setup, so I was forced to make the jump to Scale a lot sooner then I originally planned.

I installed Dragonfish on to my 32GB M.2 boot drive and repurposed my 512GB M.2 drive that used for jails in Core … now houses my APPS in Scale … plus a 256GB M.2 drive I had laying around that can be for whatever (motherboard has 2xM.2 slots)

Networking Kubernetes isn’t like jails in Core at all … so I was having some issue with Plex and not getting everything ran thru a relay that limits bandwidth. For now I just bound to “Host Network” until Eel gets released and then I’ll mess with it some more. I watched the jailmaker video by Stux and was going to try that … but it seemed a bit complicated right off the bat to me … and like I said … I don’t know what I’m doing and I’ve never messed with docker containers before …only Core jails

Anyways, Plex is up and running and accessible without using relay … Hardware transcoding is working thru the ARC GPU … I have some redundancy now, so that’s good. I might switch to ECC RAM down the road after I get all my old server parts sold ( I still have the 5800x and 2 x 16GB low profile 2666 ECC UDIMM’s left to sell)

I also might put my 10GBe SFP+ network card back in … but so far the 2.5GB NIC is doing it’s job plugged into a cheap 2.5GB switch that has 2 x 10GBe SFP ports as well

Far from recommended hardware, but it’s working for my home … so far, lol

If it works, it works, just be sure you have backups somewhere else other than on that system right.,

Movies and TV show stuff I don’t really care about … the relatively small amount of pics, family videos and what not that we have in comparison … yes. I do have back ups of those

1 Like