Set Mangled Names to No (Auxillary Parameters)

Hi, all!

I’m having some issues with an application. This application is running in a container on a separate VM and is using a drive mounted via SMB.

I’m not 100% sure that changing mangled names to no will fix the issue, but it’s a troubleshooting step I’ve seen work for some others.However, I can’t seem to figure out how to do this on SCALE.

The documentation states that there is an “Auxillary Parameters” configuration option for this purpose, but I don’t see that when I go to Services > SMB.

I have attached an image of what I see on my system.


I am on the latest stable, 24.04.

Am I missing something?

Enable the option Use Apple-style Character Encoding in the SMB share configuration itself.

Then reconnect the client/app to the share and see if it works?

I’m assuming your client is seeing “managled” filenames, due to some filenames containing “illegal characters”?

That worked! Thank you!

Yeah, for some reason, Plex and Sonarr were having issues with reading some files on my NAS drives. I’m not 100% sure why. The file names and metadata looked perfectly reasonable to me, but I guess there must have been some weird characters somewhere in there.

Should I log an issue for the Auxiliary Parameters field not being present? Or is that intentional?

The Aux-Parameter field has been removed with cobia i believe. It’s intentionally no longer there because there were problems with users setting aux parameters and a lot of problems/bug reports with them.

Ah, that makes complete sense. Should I file something to update the docs, then, so that dummies like me don’t go looking for it and get confused as to why it’s not there? :stuck_out_tongue: