Setting up smb multichannel in truenas scale

Hi i am using TrueNAS-SCALE- with the fallowing hardware

Chinese mb with 4x2.5gb intel i226-v nics
intel celeron n5105 cpu
2x 12 tb seagate exos hdd mirror
2x 8 tb wd red pro hdd mirror
32 gb ddr 4 ram

My personel computer has a nic with 2x2.5 gb intel i226v (windows 11 home)
i know i can’t reach 500MBs as my hdds are capped at around 270 MB as they are not striped only mirrored and at seperate pools but when i make transfer at least i would like to see some movements in other interfaces. Both at truenas and my windows only 1 interface seems making transfer

My truenas settings is like below:

is it normal to see no movement from other nics? or am i doing something wrong?

Thanks in advance.

My windows 11 home nic settings are like below:

Also changed my second nic to like below to make them appear at different subnets but didnt change anything.

well i will add 2 new disks to second pool in 2 days, then i will be sure if it is working or not :face_with_raised_eyebrow:

You need - to the very best of my knowledge - two NICs in TrueNAS on different subnets and in different VLANs and two NICs in the client PC in these same two subnets/VLANs.

Thanks for the reply Patrick, i’ve setuped 10.x ips for vlan10 and 20.x ips for vlan 20 from managed switch and even setup a dhcp server for them on both sides only 1 interface willing to show some movements, as shown in the pictures when 1 interface on both sides are making 2gbps transfers other seem to have byte level movements.

You cannot have DHCP on two interfaces on any given host. You need static configuration for the TrueNAS.

And only a single default gateway in the VLAN that your uplink/firewall is connected to.

well i tried static too and it didnt work. I will check when i get back home. Btw what do you mean by “single default gateway” if you mean truenas, it only lets 1 default gateway anyways, if you mean windows 11 does an ip like 192.168.20.x can use a gateway like which is in different subnet?

Only one interface should have the single default gateway configured, the other just none.

Then when you ping from the PC to the NAS in the .10 network all packets should go over one link, when you ping in the .20 network over the other one.

Assuming all /24 netmasks!

Hi Patrick, the settings above worked, apparrently there was a setting in the main switch (there are 2 managed switches, pc and truenas are connected to the small switch and then uplink to a bigger main managed switch) where i need to disable “ingress checking” at the uplink port, if not port will only allow its main vlan.
Thanks for your helps though