SMART on Truenas Scale

Dont work SMART on Truenas Scale
ERROR: smartctl takes ONE device name as the final command-line argument.
You have provided 2 device names:

You should be configuring this in Data Protection->Periodic SMART Tests, not on a per device basis. This handles muliple devices correctly

What you’re seeing is the error from the smartctl command itself, which will not issue tests on multiple devices. The TrueNAS gui handles this for you.

Tell me where I can add an argument ‘cciss,N’ in Data Protection->Periodic SMART Tests?

Ah, good question, and sorry, I’d never heard of cciss options before.

I take it this is some sort of old RAID controller where the disks aren’t directly accessible?

The man page suggests the format is:

cciss,N - [FreeBSD and Linux only] the device consists of one or more SCSI/SAS or SATA disks connected to a cciss RAID controller. The non-negative integer N (in the range from 0 to 127 inclusive) denotes which disk on the controller is monitored.

Option '-d sat,auto+...' is implicitly enabled to detect SATA disks. Use '-d scsi+cciss,N' to disable it.

To look at disks behind HP Smart Array controllers, use syntax such as:
smartctl -a -d cciss,0 /dev/cciss/c0d0 (cciss driver under Linux)
smartctl -a -d cciss,0 /dev/sg2 (hpsa or hpahcisr drivers under Linux)
smartctl -a -d cciss,0 /dev/ciss0 (under FreeBSD)

Do you see a regular /dev/sdx style device in addition to the /dev/cciss/xxxx devices?

I guess if you see both, the problem is that TNS is retaining the /dev/sdx in the command line, and that’s why it’s complaining when you add the /dev/cciss/xxxx option.

Ah, this seems relevant (though I suspect you will not like it):

tl;dr - unsupported