SMB MultiChannel and macOS Time Machine

I’ve been doing some testing with SMB Multichannel and, while MC works fine between my Mac Studio and TrueNAS Scale ( server when I connect to a regular SMB share and copy files back and forth, it only uses one channel when Time Machine is being used with an SMB Time Machine share. I get this error message on the macOS side when I run “smbutil multichannel -a”.

Any ideas?

stat_multichannel : SMBOpenServerWithMountPoint() failed for /Volumes/.timemachine/truenas4._smb._tcp.local./533F9B21-2848-44B3-BEF3-6A3AEEBAABE6/TimeMachine <TimeMachine>

stat_all_multichannel : stat_multichannel() failed for /Volumes/.timemachine/truenas4._smb._tcp.local./533F9B21-2848-44B3-BEF3-6A3AEEBAABE6/TimeMachine

smbutil: unknown status -1073741766: Permission denied

You should describe hardware (mac and TrueNAS) and network set-up.
MacOS version as well.

If that’s all clean, then the issue is Mac client or TrueNAS?

Has anyone else got it to work?

I was hoping the post might get seen by somebody that has actually done it. It’s kind of an edge case since Time Machine backups are already slow and you might not even notice unless you were looking for it since the error is non-fatal to the backup.

Client: M1 Mac Studio, macOS 14.5, integrated 10 Gbe + TB3 10 Gbe
Server: Ugreen 6800 NAS, Scale, dual integrated 10 Gbe
Flat network with primary and secondary subnets used for MC

1 Like

Its the right strategy, but see if Timemachine has any special limitations.

1 Like

Time Machine is the most active part of my pool

IIRC, Time Machine is intentionally internally throttled to be a good background process that no one will notice. This is likely to prevent network congestion since many Macs are pre-programmed by Apple to execute their TM tasks on a hourly basis.

I just started my TM for fun and while it bursts from time to time, most of the data transfer speeds were below 3MB/s per the activity monitor. Now, I am not on my 10GbE pipe right now but I think we can all agree that a 300MBPS connection allows for far higher speeds than that and my NAS has gobbled up large files at 800MB/s when I was on fiber.

So I don’t think its either the NAS nor the pipe, but rather it’s Time Machine. But I’m happy to be wrong.

I think I’ll set up MC with my Mac Mini 2018 and see if I get the same error going Mac-to-Mac. If it fails that, maybe I can figure out a way to file a bug report so I can ignore it.