SMB Public Share

Hello, I am new to TrueNAS Scale. I have a Datapool and createt a dataset.
Now I am trying to share this dataset with my Windows 10 PC using SMB.

The Problem is that I am not able to connect to my TrueNAS Server with Windows Explorer.
It says something like “Couldn’t find the network Path” - Error Code 0x80070035


I set everything I could to Read/Write Access. Stripped the ACL and give the Dataset and the Share
Permissions 777. I also set the Guest Access Checkbox and even on my Windows 10 PC I have set
“unsafe guest access to network folders” in these windows policy options.

But I can’t acces the stupid folder. I think I can’t even access my TrueNAS Server because the Error
Message come as soon as I click on the TrueNAS Symbol in Windows Explorers Network Neighbourhood.

Is there anything which I do wrong? Or what’s the best way to create a real public share where really everyone
can read and write without username/password or any other restrictions?

Have you actually setup and turned on the SMB service?

I say this because when you create a dataset you may be asked if this will be an SMB share. That does not mean the SMB service is setup nor turned on.



I got caught here too. I needed to make sure that SMB was not only shared but enabled by default to start automatically.

Yes I turned SMB on and set the Checkbox autostart. In the SMB configuration I also tried to set the Checkbox “SMB1 Support” and “NTLM v1” but nothing changed even when I turned on smb1protocol on
my Windows 10 client. I also restarted the TrueNAS server and the client PC several times but I still can’t access the share.
I will share some screenshots so maybe you guys see something wrong with it because I didn’t and
I don’t understand whats wrong with it.

Ok problem solved. I am so dump. I wish I could something blame for this but it was entirely my fault.
I directed Windows Explorer direct to the IP of the server instead of the hostname and it worked.

A short backstory:
My first attempt was to install Proxmox direct on the server and then install TrueNAS in a VM.
But I had some problems with passthrough my HDD controller so I decided to just install TrueNAS direct on that server.

Now the problem:
Before I installed Proxmox I created some Records in my DNS Server for “microwave” which should be the Proxmox installation on the server and “truenas” which should be the TrueNAS VM.
But when I decided to install TrueNAS direct on the server I forgot to remove or at least modify my Records in my DNS server.

And the thing is even when the Hostname for the TrueNAS Server is indeed “microwave” for some reason Windows Explorer shows the NetBIOS name for the SMB Server in Network Neighborhood. Which can be modified in the SMB Server Settings in TrueNAS. But because I didn’t saw any reason to change it because I thought NetBIOS was a thing from the past Windows wanted to direct me to the IP which is behind the name “truenas” and it clearly didn’t exist.

Easy as can be (when the problem is known). I modified my records in my DNS server and changed the NetBIOS name for the SMB Server to the same name as the hostname for the TrueNAS server.

It would had beed nice when the Windows Error message had shown me something like can’t acces
instead of just “couldn’t find path” because the I had saw that the IP Address was wrong
and had discovered my failure faster. But ok now I know.

1 Like