[SOLVED] Backup readonly pool

My NAS had a drive that was giving checksum errors so I replaced it but the resilver process would never complete. The whole system would restart when it got to 90%. After a few times the system got stuck in a boot loop with an error during startup. I can import the pool as read only through the shell, and when I run zpool status it shows that it is being resilvered but the percentage never changes.

I have another system running TrueNAS CORE that I would like to backup the data to, but I can’t find a way how since the GUI doesn’t see the pool as being imported. Is there a way I can copy the data to the new server?

Old System
Motherboard : MSI PRO B660M-A Micro-ATX
RAM : 2x 16GB DDR4 3600 CORSAIR Vengeance
CPU : Intel Core i5-12600K
Storage : 8x Seagate 10TB IronWolf SATA III, 1x 500GB SSD (for running TrueNAS)
Expansion cards : 1x 10GB PCI-E Network Card (onboard had issues), 1x M.2 PCIe 6 x SATA Adapter Card (motherboard doesn’t have enough SATA ports)

New System
Motherboard : Supermicro MBD-X11SCH-F
RAM : 2x 16GB DDR4 2666 ECC UDIMM
CPU : Intel Xeon E-2244G
Storage : 6x WD Red Plus WD60EFPX 6TB

I figured it out. Here’s what I did incase anyone else has the same issue.

  1. Do a fresh install of TrueNAS CORE and do NOT import the pool via the GUI (this caused a boot loop)
  2. Enabled Rsync in the services
  3. Open the Shell and enter zpool import -o readonly=on {PoolNameHere} -R /mnt
  4. After that I was able to use rsync -av {directory} {username}@{ipAddress}:{remoteDirectory} from the shell to copy the data to the new system.
1 Like