SOLVED: Booting into TrueNAS Scale on a Dell R720XD

I need some assistance with TrueNAS Scale on a Dell R720XD. The H710P Mini was IT flashed. 192GB RAM. 2.5" 250GB Samsung SSD. Front 12 3.5" drives have been removed.

I’ve got a Samsung 250GB SSD installed via the the backend drive bay for 2.5" drives. TrueNAS installer sees it (and all the other drives), with which I’m able to install TrueNAS Scale to it. However, once I am done with the install process and restart, I can’t seem to boot to it. If I use UEFI boot, it says Boot Failed: TrueNAS-0. If I use BIOS boot, it says No boot device available.

Any idea what I might be missing here?

SOLVED: used a USB to SSD adapter for the SSD drive to boot.

Do the rear disks connect to the SAS controller via the front expander backplane or to the motherboard SATA ports?

Looks like they connect to the SAS controller via the front backplane.

Hmm… I’ve had some trouble, occasionally, when booting from SAS controllers - though in my case SAS3 and the Linux stub loader, rather than GRUB.

A couple of things to try:

  1. Repeat the install, just to double check
  2. Move the rear bays to the SATA ports (with a reverse-breakout cable)
  3. Disable extraneous PCI option ROMs and stuff like that

I couldn’t figure out why I was having so much trouble with booting into TrueNAS because my other 2 TrueNAS servers (both Poweredge R720 servers) never had this issue. But then I realized, both utilized the ROM converter tray for the SSD, so there were no issues reading the SSD. Since this R720 is an XD, there is no ROM, hence why it is using the SAS backplane.

That said, although I have performed your #1 5 times, I really think it is #2 that is correct. That said, I looked for these cables, but wow, so many different choices. Do you have any recommendations?

Well, your suggestion about the SAS Controller being the issue is correct. SO, I took a USB to SATA cable I had and tested it. Booted instantly into TrueNAS. I guess this is what I will be using now. I appreciate the assistance!

You can do that long-term if you can cram everything in and secure it all.

You need an SFF-8087 reverse breakout cable, i.e. with SATA-style ports on the host side and SFF-8087 on the device side. Yes, they are different from forward breakout cables. Yes, they look identical. Yes, it’s annoying as hell.
No specific recommendations, pretty much any such cable should work.

Of course, it’s not impossible that the system firmware and/or iDRAC will complain about those disks being connected to the SATA ports… Something to investigate, perhaps.


I am going to stick with the cable adapter I installed. Despite mounting the SSD further back on the sled, unfortunately, it sticks out in the back just a bit. I tried turning the sled upside down, but I can’t push it in all the way either because the one side of the sled has a notch cut out for two prongs sticking out. I don’t want to modify either. Since the cabinet is locked all around and no one but me messes with it, I am good with that.

Again, I really appreciate your help!