[SOLVED] Existing RSYNC tasks are dead after upgrade to Dragonfish

Why would an rsync task fail after updating to Dragonfish? This is the error:

sudo: pam_open_session: Permission denied
sudo: policy plugin failed session initialization

I went to the System SSH service and the ssh connection owenssh that the Rsync task has assigned to it no longer exists and none can be added. The Rsync task uses the keychain.

Where to look for the logs for rsync?
Is there some key I’m not aware of I need to import somewhere?
Where to setup a new ssh task?

This system was upgraded from Bluefin to Cobia, run overnight and the Rsynk tasks (and cron task) worked fine and no other errors were reported. I then yesterday upgraded to Dragonfish and this morning the rsync tasks all failed with the above error. I also noticed that a script that was working fine with cron on both Bluefin and Cobia also no longer works in Dragonfish with a permission denied error. I have a feeling these issues are related but how and why in Dragonfish when they were not an issue in Bluefin or Cobia?.

It looks like the user you have selected for the rsync task has its home directory set to /nonexistent. Try changing the home directory to /var/empty. C.f. release notes for 24.04.0.

Thank you. That was the issue and the Rsync tasks are now working.

After you mentioned the release notes, I recall they did say something about the change to home directory.

We’re adding an automatic migration for this situation in 24.04.1.

1 Like