SOLVED: Install of plex did not give me the server menus

I installed the plex app and everything works fine, e.g., the Web Portal brings up what you expect. Except it doesn’t think it is a server and there are no server menus when you hit the wrench. WTF??

Check this out:

The problem is I supplied my own userID for the owner instead of using the default suggested in the install.

Bottom line: the ONLY change to make to the config is Use Host Network and leave everything else alone!!!

Nothing in the logs.

What’s the trick to getting this to work? I’m totally baffled.

The only thing odd I did was to use my own userID for ownership instead of the default.

As in the TrueNAS (host) user ID, such as 3000, instead of the Plex user ID of 972? (In the “App’s” configuration I take it?)

the uid is “apps”

Plex needs to have “apps” identity since that is who owns all the files in ix-systems dataset. So never touch the default user. it has to be apps as the owner.

2 Likes

Please elaborate.
The App comes with some UIDs assigned. Are these supposed to be changed to be for apps user and apps group?

If we set the various directories Host Path Configurations?

  • Plex Data Storage
  • Plex Configuration Storage
  • Plex Logs Storage

Do they all have to be different Host Path Configurations?

I assume the: “Additional Storage” is would be the dataset where the various media types would be stored as sub-directories?

Needless to say, as with most apps, the documentation for Plex and what these values represent are non-exisitent.
Plex True NAS Documentation

My Immediate issue is:

2024-04-29T08:11:28.543300099-04:00 [s6-init] making user provided files available at /var/run/s6/etc...exited 0.
2024-04-29T08:11:29.517975514-04:00 [s6-init] ensuring user provided files have correct perms...exited 0.
2024-04-29T08:11:29.518808295-04:00 [fix-attrs.d] applying ownership & permissions fixes...
2024-04-29T08:11:29.519343460-04:00 [fix-attrs.d] done.
2024-04-29T08:11:29.519921719-04:00 [cont-init.d] executing container initialization scripts...
2024-04-29T08:11:29.520969074-04:00 [cont-init.d] 40-plex-first-run: executing...
2024-04-29T08:11:32.492565969-04:00 Plex Media Server first run setup complete
2024-04-29T08:11:32.493017075-04:00 [cont-init.d] 40-plex-first-run: exited 0.
2024-04-29T08:11:32.494207563-04:00 [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: executing...
2024-04-29T08:11:32.497055906-04:00 [cont-init.d] 45-plex-hw-transcode-and-connected-tuner: exited 0.
2024-04-29T08:11:32.498182327-04:00 [cont-init.d] 50-plex-update: executing...
2024-04-29T08:11:32.516199404-04:00 [cont-init.d] 50-plex-update: exited 0.
2024-04-29T08:11:32.516822134-04:00 [cont-init.d] done.
2024-04-29T08:11:32.517504235-04:00 [services.d] starting services
2024-04-29T08:11:32.522945824-04:00 Starting Plex Media Server.
2024-04-29T08:11:32.523142398-04:00 [services.d] done.
2024-04-29T08:11:45.193866916-04:00 Critical: libusb_init failed
``` bash

Thanks for your help.

no. No need to change the userid it came with (which corresponds to apps).

Be sure all the files plex uses are owned by apps, otherwise Plex will not see the files.

So when I copy files in via SMB, i have to chown -R apps them for Plex to see them.

1 Like

I have spent hours and many attempts trying to deploy plex.
My immediate issue is:

Critical: libusb_init failed

Any ideas?

I have that same error. My understanding is that it is searching for a USB device that might have a library on it and failing. Unless you actually have one, it will do this and this is not a problem so ignore it.

Do you have a problem outside of this error in the logs?

I agree on the libusb. I remember getting this message too. It’s a complete head fake.

The key to plex is making sure all files are owned by apps. Otherwise, plex will not run properly.

As far as I can tell I have no USB device that might have a library on it and failing.

I’m doing this from my phone via voice, so sorry if something here doesn’t look right. I spent a lot of time trying to figure out my issues and thought I would post it somewhere if by chance it helps somebody.

I spent some time on this last night because I had issues of my own. One thing I realized is that I have a Plex pass, when I use the standard image it did not work. I used the Plex pass image without changing anything else and it worked.

Before you do anything with Plex, make sure that you’ve done the initial setup as suggested by the install documentation. If you don’t set up your network, nothing can get outside of the server, so all hope is lost anyway. You have to go to network settings and set up a DNS server. I put 8.8.8.8 into name server one and 8.8.4.4 into name server two. I have no idea why they wouldn’t put this in as default set up values, but there must be a reason. If there isn’t a reason I’m pissed. This should just work.

While you are here Make sure your default gateway is correct. This should be the IP address of your router.

If you haven’t gone through the initial setup doc and you’re still having troubles, make sure you go through this because there might be something else you’re missing here.

I was going through eliminating every variable I could and the simplest installation you can do that still works is installing with all default values. Add your media folder where it says to add an additional storage location. Make sure you can select it from the folder chooser, or I’m guessing you need to modify permissions for it to work. Not saying that this is a any clue that it will work but if you can’t see your folder here, it certainly won’t work. I used /Media as the Mount Point. In the folder chooser it looks like /mnt/tank/media because that’s where my media actually is. My media is owned by the apps user and I made a media group for it as well. Best I can tell, it’s very important that you leave the user and group that it runs on inside the container to the defaults so it actually runs inside the container on the apps group.

If you just let it install into the default IX folder, it will auto set permissions for running the app which is the simplest way to do it. I don’t know if there’s a disadvantage to this, but it did for sure work. This takes at least one variable out of the equation if you’re having troubles.

The only other thing I changed to make it work on default is you obviously have to add a claim token as well. In my case, and I have no freaking clue why, but I could not get the Claim | Plex to work from the same PC I was using to set up my server. The website would come up, but nothing would show up in the box after I hit claim. Just a blank black box. I don’t know if this is an SSL issue or what, but I went to my phone and went to the same website, logged in, and the clam token works just fine. Remember that the clam tokens have a 5-minute time out, so my suggestion is to just go and get your token after you set up the rest of the container.

1 Like

Thanks for taking the time for the response.

I have found most of the Truenas and TrueCharts to be extremely confusing, confining and they almost lack any form of documentation. (Or maybe I just can not find the documentation)

I find it funny with the blurb asking did you read the documentation check box but no link to the documentation at that point.

The little ? bubbles are a joke.

One has to see the irony that while trunas scale attempts to simplify the complex task of setting up interconnected applications on linux, it leaves the person setting it up with just as much research to do as before, because there is little to no explanation of what to do with the fields they provide in setup.

Agreed with the ? bubbles. Most of them might as well just say “Read the title of the feature I’m near. That’s what this thing does.”

I really want to like trueNas scale, but I keep asking myself how this is any easier than just running ubuntu (which is what I did before). It’s great when things just work, but when they don’t it’s the exact same 2 or 3 hours of tinkering and googling to figure out why it doesnt.

1 Like