[SOLVED] One of multiple WD Red Sata drives not detected by LSI HBA

SOLUTION: Asked a friend of mine for help, they researched a bit and found this KB450057 - Using Staggered Spin Up - 45Drives Knowledge Base
Checked the details of every disk in hdparm and indeed the faulty drive had this feature turned on. After running hdparm -s0 for the drive it started behaving normally!

Hey, I recently started my adventure with a homemade NAS. I bought a used LSI-SAS9211-8i card with two SFF-8087 to 4 Sata cables, connected 5 WD20EFRX drives and thought everything would be fine.

Turns out one of those drives isn’t detected by the HBA, even after updating the card’s firmware so that I can view the HBA settings in my uefi bios, it’s in IT mode of course.

The drive works fine when plugged into the motherboard, it’s almost identical to another drive I have, same model and firmware version.

After some testing it turns out that the drive works with the HBA after I unplug it from the motherboard and then connect it to the HBA, it keeps working after rebooting, but stops if I shut the machine down and boot it later.

I also tried the 3.3V tape mod and using the other cables - no difference. It also doesn’t work if it’s the only powered on drive.

I’m out of ideas and would love some help or random suggestions, thanks in advance :slight_smile:

Rest of the specs are: Ryzen 3600, 32GB 3200MHz Ram, ASRock B450 Pro4 R2.0, Endorfy Supremo FM5 Gold 650W PSU