SOLVED: Unable to connect apps to host volumes

Hi, I just upgraded to Dragonfish and I’m encountering an odd problem with App settings.

Previously, I was a bad boy and was running some Docker containers via the CLI to provide sonarr/prowlarr/radarr/qbittorrent as a docker compose group, but now that those apps are all available via charts I wanted to migrate over.

Problem is, I am totally stumped as to how to get storage connected in, I have ACLs set up for all the users I had used for the apps previously to the places they needed (all directories are within one single mountpoint/dataset), but now when I edit the apps and try to add storage, I am unable to select “host mount” and can only do the ixVolume option.

In Advanced Settings there’s an option to Enable Host Path Safety Checks, I wanted to turn that off as a test but after confirming it’s dangerous, I can’t save it, as when I click Save I get a little red message next to that option with “Field was not expected”, and I am unable to save.

Searching the docs and forums seems to show that what I’m looking to do would be relatively easy, I have all the apps running as the apps user/group and that is the main owner of the entire media dataset, yet I am unable to plumb any of it together.

I do have an Emby app running as well, which I have been using for months now, and that is connected to the host volume and everything seems to be OK, so I hope it’s not something where only one app can be connected or something goofy like that.

Any suggestions on how people are managing this in Dragonfish would be greatly appreciated, the new forum search is not very useful for me and I’m hoping I just missed a thread/doc that can set me straight. Thanks!

Hi @jballou. Can you confirm which version number of TrueNAS you have installed? I’m a little confused by the post, because you say you are on Dragonfish (24.04), but mention the Enable Host Path Safety Checks option, which was removed in Cobia (23.10).

It’s possible that your browser is including some cached options, causing the unexpected field error. Have you tried a hard refresh to clear the cache (ctrl+f5)?

Hi, you appear to be correct in the cache/cruft issue, I cleared my browser cache and logged back in and now the interface is significantly different. I am now able to use the storage add interface as expected. Thanks for the reply.

1 Like