Sonnar, Radarr & Lidarr lost GUI. All other jails OK

Hey everyone.

Last weekend I upgraded all my jails to the 13.3-Release. This fixed the problem I has where pkg would not reach the repository when attempting to update after upgrading the OS to 13.0-U6.1. After I completed upgrading all my jails from 12.4 to 13.2, then 13.3, everything ran perfectly and all my jails were able to update the app via pkg. I was happy.

Today however, while I was at work something happened and I am admittedly at a loss of where to look. My wife told me that when she ran into the apartment to quickly use the washroom (she’s the building manager) she heard something in my 42U rack “screaming”. Sadly she was in such a rush she had no time to look. When she got back home around 5:45, everything sounded normal. When I logged into my TrueNAS gui, I noticed an alert that said the server had an unexpected restart at 7:05 AM. (When she left the apartment around 8:00 AM, everything sounded normal…)

My other symptom is that all my jails are working normally except for Sonarr, Radarr and Lidarr. For these jails I have no GUI access. I am able to ping them from my desktop and I do get replies. Both TrueNAS GUI and when I log in via Putty report the jails are up and running. I stopped the services via Putty and ran pkg. A lib item was the only item updated. I have restarted the services to no affect. I have also restarted the jails themselves via both Putty and the TrueNAS GUI, to no avail… Out of shear desperation, I even attempted to reboot the entire server via the TrueNAS GUI, and still the same.

Sadly, at this time I am at a loss as to what I can attempt to look at next… I know I probably know, but I’m so exhausted my brain just isn’t working… Can anyone possibly point me in another direction as to what to look at?

Thanks in advance to all you wonderful people!!!

You need to revert to the 13.2 release for your jails. 13.3 introduced some new things regarding the way services operate so until TrueNAS CORE 13.3 is released, you can only use 13.2 jails.

Thanks Victor!

I think I may be out of luck… My understanding was that iocage jails would automatically create a snapshot as part of the updating the release. Clicky

However, I see that is apparently not the case…

When I run iocage snaplist the only jail I have which has a snapshot is Plex, and even then, that snapshot is from 12.4-RELEASE and all other upgrades past 12.4 did not create a snapshot.

I’m now exhausted and heading to bed before I make a sleeping mistake somewhere and reassess with fresh eyes. (Have to wake up in 3 hours to go to work as well…)

I am thinking my choices will be one of two options:

Wait until the next TrueNAS update catches up with my jails and cross my fingers…


Create new jails using the 13.2-RELEASE template, reinstall the respective app into the jail using pkg, copy over all the data from the original bad jail into the new good jail. Once I make sure it’s working OK, manually create the snapshot of the jail.

I would like to know why iocage update didn’t’ automatically create the snapshots… I’ve never had a problem like this before so I never would have thought to check…


APC UPS sound like they are screaming when they are on their last gasp after a power outage… before the power cuts out…

Is that perhaps the screaming you heard?

I suspect the restart/power glitch, whatever is perhaps a little bit unrelated to the jail issue

If you are adventurous, you could update to the 13.3 nightly version…

1 Like