Sshd_config keeps reseting, auxiliary parameters do not work

Hi, i have silly problem…
I need one simple thing: .BAT file on Windows to remotelly shutdown trueNAS server. Without login. Just “click and forget”.

To do this, i need working SSH, but it keeps asking me for password.
I don’t want enter password, I just want to “click and forget”.

So I setup id_rsa keys… but it still asks me for password.
I found I need to change in sshd_config. I added: PubkeyAuthentication yes
but file keep reverting to original after each restart.

So I added “auxiliary parameter” in SSH service. “PubkeyAuthentication yes”.
Saved. Restarted service. Rebooted.

And it still wants me to enter password.

You’re not supposed to edit the config file like that.
You are meant to add the public key in the UI under Credentials → Local Users.

I do not see such option… Is it availiable in TrueNAS-12.0-U8.1, or do I need to upgrade…?

Yes, it is; it’s in the user account settings for the user in question.

You should; the 12.0 series isn’t supported any more.

CORE seems to put it under Accounts → Users.

Some of the settings are under Services > SSH