Subnet problems

Hi, I’m quite new to this software and i have set my IP to with mask . However if i try to access the swerver from the server is not accessible. If anyone knows something about it, i appreciate the help.

Is the device you’re trying to access TrueNAS from configured with the same netmask? Is it within the same subnet?

No is not. The device is do you think that’s the problem? (

Well, yes, that’s obviously never going to work, since is outside All devices in the subnet must have the same netmask. Whether that’s a /24 or /16 is largely up to you to decide, but you probably want to stick to a /24 unless you have a very good reason not to.


Ok. I have tried multiple things and it doesnt seem to work. I change my netmask and it doesnt work. I also tried with /8 and also didnt work. Moreover its imposible to use /24 for reasons I can’t explain here (I’m part of a larger organization network )

Is the node on the same network segment? Ie no gateways/routers?

Could you setup an alias ip for the nas on the same ip network?

To transmit between different ip networks (defined by the net mask) you either need a gateway/router or to have an interface directly on the target network.

Which of course is basically what a router is.

There are no router. Just a bunch of L2 and L3 switches. The data only pass through 4 L2 siwtches and a main L3 switch in which the server is located. I have managed the ports of the switch to a specific subnet.

Yes the .1.1 is in the same node. “Could you setup an alias ip for the nas on the same ip network?” idk how that can be done. if you think thats the solution and you have any ideas i would love to hear them.

Any ideas?

If I am understanding you correctly, your instance of TrueNAS is at, and the host you are using to reach is at Yes?

You attempt to connect and get a failure to connect. That is because and are two separate networks, if the subnet mask was say, /23 or you might have better luck.

It’s not a software error, its a networking one.

not exactly. My TrueNAS server is on with (/16) and my computer is in with (it was /24 but ericloewe told me to put the same subnet mask) And they still can’t communicate